Bug 1508649 Comment 3 Edit History

Note: The actual edited comment in the bug view page will always show the original commenter’s name and original timestamp.

Continuing comment 0 - a) I haven't done a full numerical analysis so this is mostly eyeball and b) we increased the update rate for various v60.x over time, so reading the tea leaves and the conclusion might be wrong that we have a regession in a newer version.

Unfortunely that crash rate non-release builds is very low, so lack of data => no conclusion as whether or when things got worse https://crash-stats.mozilla.com/search/?signature=%3Dshutdownhang%20%7C%20_PR_MD_WAIT_CV%20%7C%20_PR_WaitCondVar%20%7C%20PR_Wait%20%7C%20PR_CWait%20%7C%20nsMsgCopy%3A%3ADoCopy&release_channel=%21release&product=Thunderbird&date=%3E%3D2018-10-18T11%3A40%3A00.000Z&date=%3C2019-01-18T11%3A40%3A00.000Z&_facets=signature&_facets=build_id&_sort=-date&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-build_id

And so another possible conclusion is that things got worse in the 60.0b* cycle, and we saw the topcrash emerge only when we significantly increased the v60 update rate.  (I'm not totally sold on this idea)

6.5.2 bp-2c6378aa-bf95-4ecb-8203-9b1410190317  Thunderbird claimed an email was sent but not saved to the Sent Folder giving me the options to Retry/Save/Not Save. I selected Save but could not verify the mail had been saved. I checked for Update and founs that an Update was claimed to be be running 

52.9.1 bp-b609baa5-f127-452d-a9a7-04b830181206 	1.Thunderbird won't save emails as always. 2. I'm getting no new emails since yesterday at Oh!Emails just arrived and the 'waiting for something' circling signal is gone! Hurrah 
52.9.1 bp-46f6bc91-9be7-40e1-8a71-9b86b0181102 	Unable to send emails - states outgoing server(SMPT) smpt.gmail is unknown. Server may be incorrectly configured. verify outgoing sever settings are correct and try again. Don't understand any of this 

https://crash-stats.mozilla.com/search/?signature=%3Dshutdownhang%20%7C%20_PR_MD_WAIT_CV%20%7C%20_PR_WaitCondVar%20%7C%20PR_Wait%20%7C%20PR_CWait%20%7C%20nsMsgCopy%3A%3ADoCopy&product=Thunderbird&date=%3E%3D2018-09-18T10%3A53%3A00.000Z&date=%3C2019-01-31T10%3A53%3A00.000Z&_facets=signature&_facets=build_id&_sort=-date&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-build_id

build           version
20180709124824  52.9.1
20181217101353  60.4.0 spike?
20181204174145  60.3.3 spike?
20181030083531  60.3.0
Continuing comment 0: 
a) I haven't done a full numerical analysis so this is mostly eyeball and 
b) update rate for various v60.x increased over time (Sept-Jan), so reading the tea leaves and the conclusion might be wrong that some newer version has a regression.

Unfortunately the crash rate or non-release builds is very low, so we lack data => and so can't determine whether or when things got worse https://crash-stats.mozilla.com/search/?signature=%3Dshutdownhang%20%7C%20_PR_MD_WAIT_CV%20%7C%20_PR_WaitCondVar%20%7C%20PR_Wait%20%7C%20PR_CWait%20%7C%20nsMsgCopy%3A%3ADoCopy&release_channel=%21release&product=Thunderbird&date=%3E%3D2018-10-18T11%3A40%3A00.000Z&date=%3C2019-01-18T11%3A40%3A00.000Z&_facets=signature&_facets=build_id&_sort=-date&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-build_id

Therefore another possible conclusion is the code went bad in the 60.0b* cycle, and the topcrash emerged only when we significantly increased the v60 update rate.  (I'm not totally sold on this idea)

6.5.2 bp-2c6378aa-bf95-4ecb-8203-9b1410190317  Thunderbird claimed an email was sent but not saved to the Sent Folder giving me the options to Retry/Save/Not Save. I selected Save but could not verify the mail had been saved. I checked for Update and founs that an Update was claimed to be be running 

52.9.1 bp-b609baa5-f127-452d-a9a7-04b830181206 	1.Thunderbird won't save emails as always. 2. I'm getting no new emails since yesterday at Oh!Emails just arrived and the 'waiting for something' circling signal is gone! Hurrah 
52.9.1 bp-46f6bc91-9be7-40e1-8a71-9b86b0181102 	Unable to send emails - states outgoing server(SMPT) smpt.gmail is unknown. Server may be incorrectly configured. verify outgoing sever settings are correct and try again. Don't understand any of this 

https://crash-stats.mozilla.com/search/?signature=%3Dshutdownhang%20%7C%20_PR_MD_WAIT_CV%20%7C%20_PR_WaitCondVar%20%7C%20PR_Wait%20%7C%20PR_CWait%20%7C%20nsMsgCopy%3A%3ADoCopy&product=Thunderbird&date=%3E%3D2018-09-18T10%3A53%3A00.000Z&date=%3C2019-01-31T10%3A53%3A00.000Z&_facets=signature&_facets=build_id&_sort=-date&_columns=date&_columns=signature&_columns=product&_columns=version&_columns=build_id&_columns=platform#facet-build_id

build           version
20180709124824  52.9.1
20181217101353  60.4.0 spike?
20181204174145  60.3.3 spike?
20181030083531  60.3.0

Back to Bug 1508649 Comment 3