Last Comment Bug 1064143 - force=1 isn't passed on for special domains
: force=1 isn't passed on for special domains
Status: RESOLVED FIXED
:
Product: Release Engineering
Classification: Other
Component: Balrog: Backend (show other bugs)
: unspecified
: x86 All
-- normal (vote)
: ---
Assigned To: Ben Hearsum (:bhearsum)
: Ben Hearsum (:bhearsum)
: Chris AtLee [:catlee]
Mentors:
Depends on: 1064622
Blocks: balrog-beta
  Show dependency treegraph
 
Reported: 2014-09-07 21:51 PDT by Nick Thomas [:nthomas]
Modified: 2014-09-08 19:56 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Nick Thomas [:nthomas] 2014-09-07 21:51:00 PDT
eg https://aus4.mozilla.org/update/3/Firefox/29.0/20140421221237/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/beta/Darwin%2013.1.0/default/default/update.xml?force=1

returns
   <patch type="complete" URL="http://download.mozilla.org/?product=firefox-33.0b1-complete&amp;os=osx&amp;lang=en-US" ....

Should end '&amp;force=1'. I can't see balrog.ini on prod to see if it's a config or code issue, but may be fallout from the blob refactoring. 

Blocks comparison of aus3.m.o and aus4.m.o.
Comment 1 User image Ben Hearsum (:bhearsum) 2014-09-08 16:46:52 PDT
Seems likely that this is my fault, I'll look into it soon. The worrying part is that tests didn't catch it :S.
Comment 2 User image Nick Thomas [:nthomas] 2014-09-08 16:50:25 PDT
Spoke to cturra on IRC before I read your reply, and it turns out we're not defining specialforcehosts for aus4.m.o at the moment. So the tests are probably in the clear.
Comment 3 User image Nick Thomas [:nthomas] 2014-09-08 19:56:34 PDT
Fixed by the config change in bug 1064622.

Note You need to log in before you can comment on or make changes to this bug.