Note: There are a few cases of duplicates in user autocompletion which are being worked on.
Last Comment Bug 1073463 - Firefox stops loading older postings on Facebook-sites' "Posts to Page" (element nesting limit reached due to bug)
: Firefox stops loading older postings on Facebook-sites' "Posts to Page" (elem...
Status: RESOLVED FIXED
[country-all] [sitewait][platform-rel...
:
Product: Tech Evangelism
Classification: Other
Component: Desktop (show other bugs)
: Trunk
: x86_64 Windows 7
-- normal with 1 vote (vote)
: ---
Assigned To: Karl Dubost :karlcow
:
:
Mentors:
https://www.facebook.com/UPCAustria
Depends on:
Blocks: 256180
  Show dependency treegraph
 
Reported: 2014-09-26 03:28 PDT by Elbart
Modified: 2017-03-20 23:04 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+


Attachments
facebook_loading_old_posts.png (90.40 KB, image/png)
2014-09-26 03:28 PDT, Elbart
no flags Details
bug.png (38.50 KB, image/png)
2014-09-26 05:44 PDT, Alice0775 White
no flags Details
"Posts To Page" (197.32 KB, image/jpeg)
2014-11-18 12:58 PST, Elbart
no flags Details
loadingstuck.png (435.16 KB, image/png)
2015-09-24 14:28 PDT, bull500
no flags Details
fb-dom-nestnestnest.png (351.28 KB, image/png)
2016-03-08 13:05 PST, Hallvord R. M. Steen [:hallvors]
no flags Details

Description User image Elbart 2014-09-26 03:28:14 PDT
Created attachment 8495862 [details]
facebook_loading_old_posts.png

- Visit URL
- Click on "Posts to page"
- Make sure that the new panel is focused, and press "End" or "Page Down" and keep it pressed to load older postings

At around August 15, the postings stop showing date and location, and soon after the posts stop appearing completely, and the page looks like the attached image.

In Chrome (fast) and IE11 (slowly) I can load back to postings made in 2013, and probably more.

The problem is reproducible with a build from 2012, so it's not a new issue.
Comment 1 User image Alice0775 White 2014-09-26 05:44:38 PDT
Created attachment 8495912 [details]
bug.png

I think this problem seems to be caused by dom nesting level limitation. ( bug 256180 )
And I think this seems to be the site bug.
Comment 2 User image Henri Sivonen (:hsivonen) (not doing reviews or reading bugmail until 2017-07-31) 2014-09-29 23:33:08 PDT
(In reply to Elbart from comment #0)
> Created attachment 8495862 [details]
> facebook_loading_old_posts.png
> 
> - Visit URL
> - Click on "Posts to page"

I see no text that reads "Posts to page" on this page.

> - Make sure that the new panel is focused, and press "End" or "Page Down"
> and keep it pressed to load older postings

However, if I scroll down without clicking anything first, I can scroll all the way to the the first post to this Facebook page.

(In reply to Alice0775 White from comment #1)
> Created attachment 8495912 [details]
> bug.png
> 
> I think this problem seems to be caused by dom nesting level limitation. (
> bug 256180 )

Since there's a script adding stuff incrementally, chances are that Firefox doesn't reach the limit in the parser but in layout. Anyway, the limit won't be going away from the parser as long as layout can't deal.

> And I think this seems to be the site bug.

Very likely.
Comment 3 User image Elbart 2014-11-18 12:58:04 PST
Created attachment 8524843 [details]
"Posts To Page"

(In reply to Henri Sivonen (:hsivonen) from comment #2)
> (In reply to Elbart from comment #0)
> > Created attachment 8495862 [details]
> > facebook_loading_old_posts.png
> > 
> > - Visit URL
> > - Click on "Posts to page"
> 
> I see no text that reads "Posts to page" on this page.

See attached image.
Comment 4 User image Karl Dubost :karlcow 2014-11-18 20:22:57 PST
I do not put this as contactready, as we still do not know what causes the issue.
Comment 5 User image bull500 2015-09-24 14:28:39 PDT
Created attachment 8665628 [details]
loadingstuck.png

I'm encountering this issue on the latest Beta - 42.0b1   
"More Stories" at the bottom refuse to load and present a animated blank box(loading) without displaying any loaded content.  
It was present on Firefox 41b9 as well.  


Tested out a safe-mode/new profile and it still happens there.  
Also tested out on another browser Opera and things are fine there. So its not a connection/facebook problem.  

I think there a problem with the way firefox pings to facebook. There's no verification system to know if its got the data or not. 
It hangs in limbo

I'm willing to help with more info if someone can guide me on whats needed.
Comment 6 User image Hallvord R. M. Steen [:hallvors] 2016-02-25 14:10:07 PST
Hey bull500 - do you still see this? I think I haven't had this problem for quite a while.
Comment 7 User image bull500 2016-02-25 15:38:54 PST
(In reply to Hallvord R. M. Steen [:hallvors] from comment #6)
> Hey bull500 - do you still see this? I think I haven't had this problem for
> quite a while.

Hey!  

My main issue was this(Solved) - https://bugzilla.mozilla.org/show_bug.cgi?id=1174899  
This was the only other bug that matched some of the troubles. 
I made an early comment here thinking both matched up.
Comment 8 User image Hallvord R. M. Steen [:hallvors] 2016-03-07 07:43:19 PST
I've tested and this still happens. Seems like an OOM or something?
Comment 9 User image Hallvord R. M. Steen [:hallvors] 2016-03-08 13:05:37 PST
Created attachment 8728073 [details]
fb-dom-nestnestnest.png
Comment 10 User image Hallvord R. M. Steen [:hallvors] 2016-03-08 13:44:25 PST
I've attached a screenshot showing that both in Firefox and Chrome the new elements in the "posts to page" lists are nested deeper and deeper. Firefox's rendering is an artifact of hitting its "max nested elements" limit (at a depth of around 200 elements I think).

We should bring this up with Facebook, it's a bug in their script causing the recursive nesting of new content being added to the page. I have not spent time on finding the exact code but it should not be too hard to locate.

Karl, can you follow up with Facebook?
Comment 11 User image Karl Dubost :karlcow 2016-03-10 18:54:59 PST
Contacted Facebook today by email
Comment 12 User image Mike Taylor [:miketaylr] (55 Regression Engineering Owner) 2017-01-30 12:57:07 PST
Karl, assuming this still repros, can you re-ping FB on the ML? Thanks.
Comment 13 User image Karl Dubost :karlcow 2017-01-31 16:05:57 PST
Alice, Does it still happen. I'm under the impression that the layout changed with regards to the screenshots in this issue?
Comment 14 User image Alice0775 White 2017-01-31 16:44:01 PST
(In reply to Karl Dubost :karlcow from comment #13)
> Alice, Does it still happen. I'm under the impression that the layout
> changed with regards to the screenshots in this issue?

The STR in comment0 is not available.
However I can reproduce the endless loading spinner and 100% cpu usage. And i can see deeply nested div.


STR
1. login facebook with any id
2. open https://www.facebook.com/UPCAustria
3. click on [VISITOR POSTS >] button at the right side pane
4. Scroll down the Visitor Posts pane and click "See More Stories" link
5. Repeat step.4 several times
Comment 15 User image Karl Dubost :karlcow 2017-01-31 18:38:46 PST
Thanks Alice!
Recontacted facebook about it. :)
Comment 16 User image Karl Dubost :karlcow 2017-03-20 20:52:24 PDT
On March 1, we got a reply from Facebook saying
> The fix for this is being rolled out and should be fully 
> out by Wednesday next week. Please let me know if this 
> is still an issue after that.

So this should be fixed by now. Alice, could you check a last time?
Many Thanks.
Comment 17 User image Alice0775 White 2017-03-20 22:39:08 PDT
(In reply to Karl Dubost :karlcow from comment #16)
> On March 1, we got a reply from Facebook saying
> > The fix for this is being rolled out and should be fully 
> > out by Wednesday next week. Please let me know if this 
> > is still an issue after that.
> 
> So this should be fixed by now. Alice, could you check a last time?
> Many Thanks.

I can verify that the problem is no longer reproduced on Nightly55.0a1.
Comment 18 User image Karl Dubost :karlcow 2017-03-20 23:04:10 PDT
Thanks a lot!
Comment 19 User image Karl Dubost :karlcow 2017-03-20 23:04:36 PDT
Changing to FIXED. as it was fixed by Facebook team.

Note You need to log in before you can comment on or make changes to this bug.