Last Comment Bug 1087933 - Provide a way to switch from thread view to composer view
: Provide a way to switch from thread view to composer view
Status: RESOLVED FIXED
:
Product: Firefox OS
Classification: Client Software
Component: Gaia::SMS (show other bugs)
: unspecified
: x86_64 Linux
-- normal (vote)
: ---
Assigned To: Augustin Trancart [:autra]
:
:
Mentors:
: 1226299 (view as bug list)
Depends on: 918970
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-23 02:39 PDT by Augustin Trancart [:autra]
Modified: 2016-01-29 06:56 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
[Message] Thread menu v1.0.pdf (866.21 KB, application/pdf)
2014-12-08 23:07 PST, Jenny Lee
no flags Details
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996 (46 bytes, text/x-github-pull-request)
2014-12-24 07:38 PST, Augustin Trancart [:autra]
felash: review+
Details | Review | Splinter Review

Description User image Augustin Trancart [:autra] 2014-10-23 02:39:36 PDT
As of bug 918970, we now redirect to a thread (if it exists) from the contact app. 

We should provide a way to switch from a thread view to the composer view. The thread participant recipient must be in the new message recipient, and if the user was writing a message, it should be kept when switching to a new message.
Comment 1 User image Augustin Trancart [:autra] 2014-10-23 02:42:02 PDT
Here it is. Should I NI Jenny to validate the description?
Comment 2 User image Julien Wajsberg [:julienw] 2014-10-23 06:49:18 PDT
Hey Jenny,

this is a follow-up of your comment in Bug 918970 comment 55 :) This is also one of the things we discussed by mail. NI you so that you don't forget ;)
Comment 3 User image Julien Wajsberg [:julienw] 2014-10-24 03:41:19 PDT
Forgot to NI Jenny in comment 2 :)
Comment 4 User image Jenny Lee 2014-10-26 20:25:20 PDT
Hi there! I believe I'll be able to work on this in late November after 2.2 specs are delivered. Will get back to this, thanks!
Comment 5 User image Augustin Trancart [:autra] 2014-12-08 08:21:56 PST
Hey Jenny! 

Did you have time to work on this? Thanks!
Comment 6 User image Jenny Lee 2014-12-08 23:07:39 PST
Created attachment 8533556 [details]
[Message] Thread menu v1.0.pdf

Hello, see attached for first version of spec ;) Thanks!
Comment 7 User image Julien Wajsberg [:julienw] 2014-12-08 23:09:31 PST
Just a notice to Augustin: don't pay attention to the design which uses next design of building blocks; just pay attention to the UX flow.
Comment 8 User image Augustin Trancart [:autra] 2014-12-24 07:38:08 PST
Created attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996
Comment 9 User image Augustin Trancart [:autra] 2014-12-24 07:39:08 PST
Hey Julien! I NI you because I have some questions about implementations. The patch is not ready yet. I need to write some unit tests, and maybe some marionette tests as well?
Comment 10 User image Julien Wajsberg [:julienw] 2014-12-24 10:28:23 PST
Answered on github :)
Note that the "feedback" flag is especially useful for such uses !

Marionette tests could be nice, especially because we'll eventually implement 2 different objects for the thread panel and the composer panel, and we don't want that this regresses.
Comment 11 User image Augustin Trancart [:autra] 2015-05-16 01:39:48 PDT
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Hey Julien,

It's been a long time, but here you are! My patch's updated \o/

For testing, I only added marionette tests. They seemed more relevant to me than unit testing there, but feel free to tell me if you see a good candidate for unit testing.

Thanks.
Comment 12 User image Julien Wajsberg [:julienw] 2015-08-12 06:24:25 PDT
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

As we discussed, this needs to be rebased now that bug 1162030 landed. Sorry about that !

Fortunately now this part won't change much for hopefully a long time :)

I gave some directions on github, I hope this won't be too difficult now :)
Comment 13 User image Augustin Trancart [:autra] 2015-10-27 02:31:10 PDT
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Hey Julien,

Here is the second part, now a lot more simpler with drafts. As the patch is really different than before, I thought more relevant not to push follow ups commit, but starting over instead. Please r?
Comment 14 User image Julien Wajsberg [:julienw] 2015-10-27 10:27:11 PDT
If that's fine to you, I'd like to wait for after the 2.5 branching before landing this. So it's quite lower priority for me during this week. I'll look at it for sure next week, but maybe this week if I have time :)
Comment 15 User image Augustin Trancart [:autra] 2015-10-27 10:56:11 PDT
Completely fine, I didn't expect this to land in 2.5 :-)
Comment 16 User image Augustin Trancart [:autra] 2015-11-11 06:49:13 PST
Hey Julien, just a little reminder for you to review this, whenever you can :-)
Comment 17 User image Julien Wajsberg [:julienw] 2015-11-13 08:27:09 PST
yeah I know, crazy times :/ I know you're in holiday during this week and I'm sorry I was as busy :/
Comment 18 User image Julien Wajsberg [:julienw] 2015-11-19 10:57:10 PST
*** Bug 1226299 has been marked as a duplicate of this bug. ***
Comment 19 User image Julien Wajsberg [:julienw] 2015-11-19 11:15:31 PST
I left some comments already. I think you can already work on the integration tests, as they won't likely change even with any change I can ask on the main code. I'll give you more comments on the main code tomorrow.

Sorry again for the delay !
Comment 20 User image Julien Wajsberg [:julienw] 2015-11-21 15:38:07 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Left comments on github :)

Please ping me in case you have questions !
Thanks again for your work, this is really good !  And sorry for the delay...
Comment 21 User image Augustin Trancart [:autra] 2015-11-30 03:20:41 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Hey Julien, another try! Please r?
Comment 22 User image Julien Wajsberg [:julienw] 2015-12-01 08:22:25 PST
Hey Matej,

can you have a look at the strings in the spec attachment 8533556 [details] ?

What I'd like to double check is the new string "Add recipient". It will be in the menu that's appearing when the user taps the top right button. And the goal is to move to a prefilled "new message" panel so that the user can add more recipients to this message.

That's why I would favor the string "Add more recipients" instead of "Add recipient". What do you think ? Maybe you'll have better ideas as well :)
Comment 23 User image Julien Wajsberg [:julienw] 2015-12-01 08:23:05 PST
Note that the current patch uses "Add Recipients" (with a final 's' and a capital letter at 'Recipient' :) ).
Comment 24 User image Matej Novak [:matej] 2015-12-01 08:54:52 PST
(In reply to Julien Wajsberg [:julienw] from comment #22)
> Hey Matej,
> 
> can you have a look at the strings in the spec attachment 8533556 [details] ?
> 
> What I'd like to double check is the new string "Add recipient". It will be
> in the menu that's appearing when the user taps the top right button. And
> the goal is to move to a prefilled "new message" panel so that the user can
> add more recipients to this message.
> 
> That's why I would favor the string "Add more recipients" instead of "Add
> recipient". What do you think ? Maybe you'll have better ideas as well :)

"Recipient" feels a bit cold and technical. Could we say something like "Add someone else" instead?

I actually don't mind it being singular, though. Saying "recipients" makes it feel like it's specifically for adding more than one person, but may lead someone to wonder how they just add one more.
Comment 25 User image Julien Wajsberg [:julienw] 2015-12-02 08:19:28 PST
"Add someone else" is maybe too generic though. Especially "Add", I'm not sure this convey enough meaning.

Another word could be "receiver", but it's really the same feeling.

More ideas:
* "Include more participants"
* "Include someone else"
Comment 26 User image Matej Novak [:matej] 2015-12-14 08:21:23 PST
(In reply to Julien Wajsberg [:julienw] from comment #25)
> "Add someone else" is maybe too generic though. Especially "Add", I'm not
> sure this convey enough meaning.
> 
> Another word could be "receiver", but it's really the same feeling.
> 
> More ideas:
> * "Include more participants"
> * "Include someone else"

I like the second one here. It's friendlier.
Comment 27 User image Julien Wajsberg [:julienw] 2015-12-16 09:14:10 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

added few more comments. We're closer than ever !

This is really cool !
Comment 28 User image Augustin Trancart [:autra] 2016-01-06 13:27:37 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

hi Julien, here is another iteration, please r?
Comment 29 User image Julien Wajsberg [:julienw] 2016-01-07 05:33:27 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Small nit in the test, I think we can do a cleaner job with the keyboard handling.

We're nearly there !
Comment 30 User image Augustin Trancart [:autra] 2016-01-16 00:34:03 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Hey Julien please r? again :-)
Comment 31 User image Julien Wajsberg [:julienw] 2016-01-18 05:27:50 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Sorry Augustin, it's orange :(

https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=8d832d45e4308c9319c0a56e539a4bbbfb5a2a6d&selectedJob=3389822

Moreover I wanted to mutualize things in one place, here I think it's better to use it in lib/keyboard...
Comment 32 User image Augustin Trancart [:autra] 2016-01-28 07:42:24 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

Hey Julien,

Ooops! Corrected :-)

Also, I've tried to refit this as you wanted, but disclaimer: I'm not sure to have understood it properly :-)

Please r?
Comment 33 User image Julien Wajsberg [:julienw] 2016-01-28 10:13:41 PST
Comment on attachment 8541259 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/26996

I left some small nits but r=me once you fix them and you check the SMS tests are green.

Thanks a lot, this is a great patch !
Hopefully it won't be the final one ;)
Comment 34 User image Julien Wajsberg [:julienw] 2016-01-28 10:14:00 PST
Don't forget to squash as well, of course
Comment 35 User image Augustin Trancart [:autra] 2016-01-29 06:23:45 PST
Yay \o/
Comment 36 User image Julien Wajsberg [:julienw] 2016-01-29 06:56:43 PST
master: 4f0e2a1a42a2d049b6fe8f4f095cdcdf0fd5465c

Note You need to log in before you can comment on or make changes to this bug.