Last Comment Bug 1118281 - Make reset-gaia for b2g-emulator often stalls
: Make reset-gaia for b2g-emulator often stalls
Status: RESOLVED WONTFIX
:
Product: Firefox OS Graveyard
Classification: Graveyard
Component: Gaia::Build (show other bugs)
: unspecified
: x86_64 Linux
defect
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
Regressions:
Regressed by:
 
Reported: 2015-01-06 07:27 PST by Robert Wood [:rwood]
Modified: 2016-02-16 11:00 PST (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Robert Wood [:rwood] 2015-01-06 07:27:09 PST
Start the b2g-emulator, then make the gaia raptor profile (/gaia/make raptor). Often the make process completely stalls and hangs forever. When that happens, if I open a second terminal window and "poke" adb (i.e. adb logcat), then the make process suddenly wakes up and keeps going and finishes. I am on Ubuntu 14.04.
Comment 1 User image Robert Wood [:rwood] 2015-01-23 08:20:52 PST
This actually happens several times during 'make reset-gaia' and is very annoying. If I don't ping adb in a different terminal during the make (i.e. adb shell, exit) then gaia make just hangs indefinitely. My ubuntu (14.04) has the newest version of adb (android-tools-adb).
Comment 2 User image Robert Wood [:rwood] 2015-02-10 12:05:33 PST
Hi Fabrice, do you know whom could have a look at this please? This is blocking some fxos-performance automation development. Thanks!
Comment 3 User image [:fabrice] Fabrice Desré 2015-02-13 00:31:27 PST
I'm not sure... Dave may have an idea?
Comment 4 User image Dave Hylands [:dhylands] 2015-02-13 07:50:27 PST
I'm not sure.

There seems to be some emulator issues. There is a networking issue which sound like its very similar to what you're describing (data seems to be sent from the emulator and never shows up on the other side) which affects the automated test suite.
Comment 5 User image Dave Hylands [:dhylands] 2015-02-13 13:05:49 PST
I was able to reproduce this in the B2G-emulator-KK.

I fired it up and did make reset-gaia. It seems to hang in the same spot:

> 2015-02-13 12:41:10: basic_code_modules.cc:88: INFO: No module at 0x2ae61c65d201
> 2015-02-13 12:41:10: basic_code_modules.cc:88: INFO: No module at 0x60080
...this seems to be a place where it hangs...
> push: /home/work/B2G-emulator-KK/gaia/profile/webapps/ftu.gaiamobile.org/manifest.webapp -> //system> /b2g/webapps/ftu.gaiamobile.org/manifest.webapp
> push: /home/work/B2G-emulator-KK/gaia/profile/webapps/addon2.gaiamobile.org/application.zip -> //system/b2g/webapps/addon2.gaiamobile.org/application.zip

In one of my runs, it hung there and I had previously had an adb shell open and had typed the top command but not just pressed return. I let it sit there for a while (several minutes) and then pressed RETURN in the adb shell window.

And it continued.

If I leave top running in the adb shell then the reset-gaia seems to go through to completion without any further intervention.

Can you try a script like the following (I called it reset-gaia.sh)

> #!/bin/sh
> 
> adb shell top > /dev/null &
> TOP_PID=$!
> 
> make reset-gaia
> 
> kill ${TOP_PID}
Comment 6 User image Robert Wood [:rwood] 2015-02-17 07:59:58 PST
Thanks Dave, I'll try that workaround. It's better than mine, I was using a script to do an 'adb devices' every 30 seconds. Btw, when I try to make gaia for the emulator-kk, using the nightly emulator-kk builds, it always fails saying the emulator's file system is read-only. Same with emulator-kk-debug. Which emulator-kk build did you use? It doesn't happen when I build my own emulator-kk, but was wondering if there is some kind of start up flag or something so I can use the nightly emulator-kk builds? Thanks.
Comment 7 User image Robert Wood [:rwood] 2015-02-18 08:31:09 PST
Your workaround in comment 5 works great, thanks Dave. And disregard my comment 6 about the write-only file system issue, looks like if I start the gaia make immediately after adb sees the emulator it works fine; maybe a timing issue with remount or something.
Comment 8 User image Dave Hylands [:dhylands] 2015-02-23 14:10:17 PST
Normally the system partition is mounted read-only, and an adb remount needs to be done to make it writable.
Comment 9 User image Robert Wood [:rwood] 2015-03-04 07:20:29 PST
Is there anyone who can look at this? Yes the workaround in comment 5 works (most times) but the issue should really be fixed if possible... thanks!

Note You need to log in before you can comment on or make changes to this bug.