Last Comment Bug 1155112 - Disconnect the link clicker as the link generator leaves the conversation
: Disconnect the link clicker as the link generator leaves the conversation
Status: RESOLVED INCOMPLETE
:
Product: Hello (Loop)
Classification: Graveyard
Component: Client (show other bugs)
: unspecified
: All All
defect
P3 normal 30
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 1125082 (view as bug list)
Depends on:
Blocks: 1125082
  Show dependency treegraph
Regressions:
Regressed by:
 
Reported: 2015-04-16 02:54 PDT by Romain Testard [:RT]
Modified: 2016-10-11 12:43 PDT (History)
5 users (show)
shell: firefox-backlog+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

User Story
As a link clicker, I want to be disconnected from the conversation when the link generator leaves the conversation so that I can't leave my camera running without noticing.

Acceptance criteria:
* When a link clicker is in a conversation, if the link generator leaves first intentionally, disconnect the link clicker automatically and prompt him an informational message about what happened with an option to rejoin:

The other person has left the conversation.
[Rejoin]

* When a link clicker is in a conversation, if the link generator leaves first non intentionally (network error or other), disconnect the link clicker automatically and prompt him an informational message about what happened with an option to rejoin:

An error occurred and you were both disconnected from the conversation.
[Rejoin]      
Description User image Romain Testard [:RT] 2015-04-16 02:54:07 PDT
As a link clicker, I want to be disconnected from the conversation when the link generator leaves the conversation so that I can't leave my camera running without noticing.

Acceptance criteria:
* When a link clicker is in a conversation, if the link generator leaves first, disconnect the link clicker automatically 
* When disconnected the link clicker is taken to the same page as if he had disconnected himself.
Comment 1 User image Romain Testard [:RT] 2015-04-16 02:56:27 PDT
Sevaan, does this look right in terms of experience?
Comment 2 User image Sevaan Franks [:sevaan] 2015-04-16 02:59:24 PDT
Thumbs up from me.
Comment 3 User image Romain Testard [:RT] 2015-04-16 03:06:19 PDT
Shell, this feels like a high value/low effort bug. Maybe a good first bug?
Comment 4 User image :shell escalante 2015-04-16 08:45:31 PDT
talked with gavin - not "good first bug" (easy for new, outside devs to take) P2?

Dan, can you get an estimate how hard this would be?  If it's a fairly simple bug - it would have a good impact to a confusing user scenario.
Comment 5 User image Mark Banner (:standard8) 2015-04-29 05:46:13 PDT
I think we're missing part of the user story here.

RT:

- what should the UX be if the remote peer is disconnected due to a network issue or something?
- Do we want any message other than just "How was your conversation?" ?
Comment 6 User image Romain Testard [:RT] 2015-04-29 06:03:35 PDT
(In reply to Mark Banner (:standard8) from comment #5)
> I think we're missing part of the user story here.
> 
> RT:
> 
> - what should the UX be if the remote peer is disconnected due to a network
> issue or something?
> - Do we want any message other than just "How was your conversation?" ?

Fair point, seems like we need to cover these scenarios more appropriately.
I added these as acceptance criteria to the bug.
Matej/Sevaan can you please help regarding the messaging to the user in these scenarios?
Comment 7 User image Matej Novak [:matej] 2015-04-29 09:41:03 PDT
Here are some options for both:


* When a link clicker is in a conversation, if the link generator leaves first intentionally, disconnect the link clicker automatically and prompt him an informational message about what happened (MESSAGE 1 TBD) with an option to rejoin.

The other person left the conversation and you were automatically disconnected. [Rejoin] [Cancel]

The other person has left the conversation. Would you like to rejoin? [Yes] [No]

You have automatically left the conversation because the other person disconnected. [Rejoin] [Cancel]


* When a link clicker is in a conversation, if the link generator leaves first non intentionally (network error or other), disconnect the link clicker automatically and prompt him an informational message about what happened (MESSAGE 2 TBD) with an option to rejoin.

An error occurred and you were both disconnected from the conversation. [Rejoin] [Cancel]

The other person experienced an error and you were automatically disconnected. [Rejoin] [Cancel]

You have automatically left the conversation because the other person experienced an error. [Rejoin] [Cancel]
Comment 8 User image Sevaan Franks [:sevaan] 2015-04-29 11:52:15 PDT
I like: 

> The other person has left the conversation. Would you like to rejoin? [Yes]
> [No]

> * When a link clicker is in a conversation, if the link generator leaves
> first non intentionally (network error or other), disconnect the link
> clicker automatically and prompt him an informational message about what
> happened (MESSAGE 2 TBD) with an option to rejoin.
> 
> An error occurred and you were both disconnected from the conversation.
> [Rejoin] [Cancel]
> 

I don't think we need a 'No' or 'Cancel' button though. Just a button that says "Rejoin" should suffice.
Comment 9 User image Romain Testard [:RT] 2015-04-30 00:07:32 PDT
+1 to Sevaan's comments.
I amended the US to reflect this.
Comment 10 User image :shell escalante 2015-06-08 07:23:02 PDT
*** Bug 1125082 has been marked as a duplicate of this bug. ***
Comment 11 User image Mark Banner (:standard8) 2016-10-11 12:43:22 PDT
Support for Hello/Loop has been discontinued.

https://support.mozilla.org/kb/hello-status

Hence closing the old bugs. Thank you for your support.

Note You need to log in before you can comment on or make changes to this bug.