Last Comment Bug 1186896 - ./mach update-uuids is broken from the recent IDL Parser changes
: ./mach update-uuids is broken from the recent IDL Parser changes
Status: RESOLVED FIXED
:
Product: Firefox Build System
Classification: Developer Infrastructure
Component: Mach Core (show other bugs)
: Trunk
: Unspecified Unspecified
-- normal
: mozilla42
Assigned To: Peter Elmers [:new_one]
:
: Kim Moir [:kmoir] ET
Mentors:
Depends on:
Blocks: 1183291
  Show dependency treegraph
 
Reported: 2015-07-23 06:47 PDT by Ryan VanderMeulen [:RyanVM]
Modified: 2018-03-02 12:23 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Fix import statements for mach update-uuids (1.91 KB, patch)
2015-07-23 08:03 PDT, Peter Elmers [:new_one]
gps: review+
Details | Diff | Splinter Review

Description User image Ryan VanderMeulen [:RyanVM] 2015-07-23 06:47:41 PDT
ryanvm@ubuntu:~/repos/mozilla-inbound$ ./mach update-uuids nsIAudioChannelAgent
Error running mach:

    ['update-uuids', 'nsIAudioChannelAgent']

The error occurred in the implementation of the invoked mach command.

This should never occur and is likely a bug in the implementation of that
command. Consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'module' object has no attribute 'IDLParser'

  File "/home/ryanvm/repos/mozilla-inbound/tools/mach_commands.py", line 183, in update_uuids
    parser = xpidl.IDLParser(outputdir=tmpdir)
Comment 1 User image Peter Elmers [:new_one] 2015-07-23 08:03:56 PDT
Created attachment 8637934 [details] [diff] [review]
Fix import statements for mach update-uuids

Updated two import statements in mach_commands to the new path of the xpidl module. Grepped for any other "import xpidl" in the code base and found none outside the idl-parser itself.
Comment 2 User image Ryan VanderMeulen [:RyanVM] 2015-07-23 08:37:28 PDT
Comment on attachment 8637934 [details] [diff] [review]
Fix import statements for mach update-uuids

I'm not a peer of this code.
Comment 3 User image Gregory Szorc [:gps] 2015-07-23 13:37:02 PDT
Comment on attachment 8637934 [details] [diff] [review]
Fix import statements for mach update-uuids

Review of attachment 8637934 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks for fixing!
Comment 4 User image Peter Elmers [:new_one] 2015-07-23 14:20:12 PDT
(In reply to Gregory Szorc [:gps] from comment #3)
> Comment on attachment 8637934 [details] [diff] [review]
> Fix import statements for mach update-uuids
> 
> Review of attachment 8637934 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Thanks for fixing!

Thanks for review! Should I run any tests, or is this ready for check in?
Comment 5 User image Gregory Szorc [:gps] 2015-07-27 14:24:18 PDT
(In reply to Peter Elmers [:new_one] from comment #4)
> Thanks for review! Should I run any tests, or is this ready for check in?

Please use needinfo! I almost missed this and only got to it just now because I'm behind on non-flagged bugmail.

As long as it works locally, this is good for checkin.
Comment 6 User image Peter Elmers [:new_one] 2015-07-27 14:48:42 PDT
Ah, will use needinfo next time! The fix does work locally.
Comment 8 User image Ryan VanderMeulen [:RyanVM] 2015-07-28 11:43:48 PDT
https://hg.mozilla.org/mozilla-central/rev/992a26539e87

Note You need to log in before you can comment on or make changes to this bug.