Last Comment Bug 1200612 - If you open Network Monitor in about:newtab (e10s only) and then open any web page, then Network Monitor closes
: If you open Network Monitor in about:newtab (e10s only) and then open any we...
Status: RESOLVED DUPLICATE of bug 1068400
:
Product: DevTools
Classification: Components
Component: General (show other bugs)
: Trunk
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Patrick Brosset <:pbro>
Mentors:
Depends on: 1068400
Blocks: dte10s
  Show dependency treegraph
 
Reported: 2015-09-01 06:41 PDT by Kostas
Modified: 2018-06-13 10:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Kostas 2015-09-01 06:41:03 PDT
To reproduce (Nightly 43.0a1 x64 2015-08-31, in win10 x64)
- open an e10s window, and a new tab (about:newtab)
- open Network Monitor (via menu button or via Ctrl+Shift+Q)
- open any web page, eg. https://www.mozilla.org/en-US/
You'll see that the Network Monitor immediately closes.

This only happens in a e10s window.
Also, there isn't any relevant entry in Browser Toolkit|Console
when this occurs.
Comment 1 User image J. Ryan Stinnett [:jryans] 2015-09-01 06:49:26 PDT
I am pretty sure this is the same as bug 1068400, so let's depend on it for now.

The issue is that while you may be using an e10s window, about:newtab forces itself to be loaded in main process for the moment, while navigating to random websites does load in the content process.  The toolbox does not handle this process transition.

It will effectively be "fixed" soon, as about:newtab will soon load in the child process as well.
Comment 2 User image Patrick Brosset <:pbro> 2015-09-01 07:16:56 PDT
Correct. And this is the case for any tool, not just the network monitor.
Comment 3 User image Brad Lassey [:blassey] (use needinfo?) 2015-09-01 13:24:19 PDT

*** This bug has been marked as a duplicate of bug 1068400 ***

Note You need to log in before you can comment on or make changes to this bug.