Closed Bug 1214211 Opened 9 years ago Closed 5 years ago

sort out pagination code

Categories

(support.mozilla.org :: Code Quality, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: willkg, Unassigned)

Details

Kitsune has two classes named Paginator that do two different things. Further, Django has its own Paginator that one of the Kitsune Paginators extends with some helpful "don't do a .count() call" kind of thing.

It's terrible that they're all named Paginator and reading the resulting code is really hard because you don't know which Paginator is which.

This bug covers refactoring that code so it's less crazy.

One possibility is to rename Paginator in kitsune/sumo/utils.py to CountPaginator since that's its whole purpose in life. Then either build in the fancy bits from kitsune/sumo/helpers.py Paginator or name that one PaginatorBlock or something like that since it's template-specific. That fixes some naming and hopefully reduces the confusion. It'd be good to look at the code and figure out what we can jettison altogether. Do we use all those Paginators? Where? Why?
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.