Last Comment Bug 1236152 - windows 10 firefox does not render correctly after reopen from minimized window
: windows 10 firefox does not render correctly after reopen from minimized window
Status: RESOLVED DUPLICATE of bug 1232042
gfx-noted
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: 43 Branch
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan] (PTO through 8/30)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-01 10:54 PST by jigar shah
Modified: 2016-02-09 17:04 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fullscreen capture 01-01-2016 194503.bmp (3.87 MB, image/bmp)
2016-01-01 10:54 PST, jigar shah
no flags Details
Address bar and menubar also not painted correctly (92.74 KB, image/png)
2016-01-02 05:09 PST, jigar shah
no flags Details
After 'show desktop' minimize...reopened and it showsup like above (337.20 KB, image/png)
2016-01-02 05:14 PST, jigar shah
no flags Details
safemode graphics info (458.26 KB, image/png)
2016-01-11 14:29 PST, jigar shah
no flags Details
fresh profile reproduced (1.33 MB, image/png)
2016-01-11 14:30 PST, jigar shah
no flags Details
fresh profile graphics info (528.64 KB, image/png)
2016-01-11 14:30 PST, jigar shah
no flags Details

Description User image jigar shah 2016-01-01 10:54:17 PST
Created attachment 8703286 [details]
Fullscreen capture 01-01-2016 194503.bmp

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151223140742

Steps to reproduce:

windows 10 yoga 3 pro - i right click and it shows black patch


Actual results:

shows black patch-once i hover mouse it shows something


Expected results:

menu should render correctly
Comment 1 User image YF (Yang) 2016-01-01 12:13:35 PST
Can you upload the attachment again? it seems be corrupted on the server, see also bug 1236161.
Comment 2 User image jigar shah 2016-01-02 05:09:18 PST
Created attachment 8703335 [details]
Address bar and menubar also not painted correctly

Its not only context menu...regular windows also not painted correctly. no issue with other browsers or app
Comment 3 User image jigar shah 2016-01-02 05:14:15 PST
Created attachment 8703336 [details]
After 'show desktop' minimize...reopened and it showsup like above
Comment 4 User image :Gijs 2016-01-11 04:15:43 PST
Can you reproduce this in safe mode?

Can you go to about:support (Help > troubleshooting information) and copy-paste the "grahpics" section into a comment here?
Comment 5 User image jigar shah 2016-01-11 14:29:14 PST
Created attachment 8706610 [details]
safemode graphics info
Comment 6 User image jigar shah 2016-01-11 14:30:08 PST
Created attachment 8706613 [details]
fresh profile reproduced
Comment 7 User image jigar shah 2016-01-11 14:30:58 PST
Created attachment 8706615 [details]
fresh profile graphics info
Comment 8 User image :Gijs 2016-01-12 01:42:45 PST
(In reply to jigar shah from comment #5)
> Created attachment 8706610 [details]
> safemode graphics info

But did you reproduce the issue in safe mode, or did it go away in safe mode?

Milan, this looks like a relatively up-to-date Intel driver, but with a large screen (3200px wide). Known issue?
Comment 9 User image Milan Sreckovic [:milan] (PTO through 8/30) 2016-01-12 06:17:03 PST
Bas, can you reproduce?  And, yes, having the information on whether the safe mode "saves" us is critical here.
Comment 10 User image Bas Schouten (:bas.schouten) 2016-01-12 06:55:05 PST
(In reply to Milan Sreckovic [:milan] from comment #9)
> Bas, can you reproduce?  And, yes, having the information on whether the
> safe mode "saves" us is critical here.

I don't see any artifacts like this, I don't have HD graphics 5300 to try and reproduce either though.
Comment 11 User image jigar shah 2016-01-12 08:14:51 PST
Safe mode its not reproducible. With fresh profile it is.
Comment 12 User image Milan Sreckovic [:milan] (PTO through 8/30) 2016-01-12 10:35:58 PST
Jeff, do we have (or can we get) this hardware in Toronto?
Comment 13 User image Ryan VanderMeulen [:RyanVM] 2016-02-08 12:31:08 PST
I have similar issues on my system. Happy to lend my system to the cause if more info is needed.
Comment 14 User image Ryan VanderMeulen [:RyanVM] 2016-02-08 12:31:47 PST
I'm on a 4K monitor as well.
Comment 15 User image Milan Sreckovic [:milan] (PTO through 8/30) 2016-02-08 13:49:46 PST
Possibly a duplicate of bug 1232042; I understand the patches on that bug are not quite right, but if you can try a build with those and let us know if the problem goes away, it'll help.
Comment 16 User image Ryan VanderMeulen [:RyanVM] 2016-02-09 15:32:20 PST
I've been running with the patch from bug 1232042 applied locally for the last day and haven't had a single invalidation issue when restoring from minimized since. I've been trying to minimize more than usual too in an effort to hit the bug.
Comment 17 User image Milan Sreckovic [:milan] (PTO through 8/30) 2016-02-09 17:04:10 PST
Let's call it a duplicate of 1232042.

*** This bug has been marked as a duplicate of bug 1232042 ***

Note You need to log in before you can comment on or make changes to this bug.