Last Comment Bug 1279288 - Get icecream working on OSX compiling against an x86_64 cluster
: Get icecream working on OSX compiling against an x86_64 cluster
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Gregory Szorc [:gps]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-06-09 10:35 PDT by Benoit Girard (:BenWa)
Modified: 2016-07-18 11:45 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP Instructions (final steps will be much easier) (4.10 KB, text/plain)
2016-06-09 10:42 PDT, Benoit Girard (:BenWa)
no flags Details

Description User image Benoit Girard (:BenWa) 2016-06-09 10:35:18 PDT
Since we got bug 927952 working in Toronto we've got a fairly decent x86_64 cluster. We decided we only wanted to maintain a single cluster. Icecream lets you cross compile if you provide a suitable toolchain.
Comment 1 User image Benoit Girard (:BenWa) 2016-06-09 10:42:00 PDT
Created attachment 8761737 [details]
WIP Instructions (final steps will be much easier)

This nearly works but when going through ICECC on a (the first?) .mm file I get the following:
ICECC[6841] 19:45:31: flush_writebuf() failed Broken pipe
ICECC[6841] 19:45:31: write of source chunk to host 192.168.1.3
ICECC[6841] 19:45:31: failed  Broken pipe
ICECC[6841] 19:45:31: got exception 15 (192.168.1.3)

It works if I manually compile it on Ubuntu but it's failing to send. I'll attach a debugger when I can.
Comment 2 User image Benoit Girard (:BenWa) 2016-06-10 16:04:31 PDT
Upstream request:
https://github.com/icecc/icecream/pull/160

Closing since locally we're using my branch.

Note You need to log in before you can comment on or make changes to this bug.