Closed Bug 1296506 Opened 8 years ago Closed 2 years ago

Rename some method names which look for an editable node

Categories

(Core :: DOM: Editor, task, P5)

task

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: masayuki, Unassigned)

References

(Blocks 1 open bug)

Details

Some methods in editor look for a editable node, but it's not explained by the method name. So, we should rename them as:

* HTMLEditor::GetNextHTMLNode() -> HTMLEditor::GetNextEditableNode()
* HTMLEditor::GetPriorHTMLNode() -> HTMLEditor::GetPrevEditableNode()
* HTMLEditor::GetNextHTMLSibling() -> HTMLEditor::GetNextEditableSibling()
* HTMLEditor::GetPriorHTMLSibling() -> HTMLEditor::GetPrevEditableSibling()

(I like "Prev" better than "Prior" because a lot of code use it as opposite word of "Next" and it's same length as "Next".)
The first two also only return leaf nodes, which is practically speaking an even more critical detail, so I suggest GetPrev/NextEditableLeafNode() for the first two.  Otherwise agreed.
Thanks you. I'll suggest to use this bug in Hacker event of Mozilla Japan at this weekend.
Priority: -- → P3

Bulk-downgrade of unassigned, 4 years untouched DOM/Storage bugs' priority.

If you have reason to believe this is wrong (especially for the severity), please write a comment and ni :jstutte.

Severity: normal → S4
Priority: P3 → P5

Now, the sacn utility methods have an option argument which is self-documenting.

Status: NEW → RESOLVED
Type: defect → task
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.