Last Comment Bug 1313418 - [e10s] Dropdown menu list is using wrong font family & size and have too much useless space between items
: [e10s] Dropdown menu list is using wrong font family & size and have too much...
Status: VERIFIED DUPLICATE of bug 1300784
: nightly-community
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: 48 Branch
: x86_64 Windows 7
-- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2016-10-27 10:02 PDT by Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
Modified: 2017-07-28 03:25 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
e10s disabled.png (3.86 KB, image/png)
2016-10-27 10:03 PDT, Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
no flags Details
e10s enabled.png (3.72 KB, image/png)
2016-10-27 10:04 PDT, Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
no flags Details
Firefox 51 [e10s=enabled].png (19.50 KB, image/png)
2016-10-27 23:56 PDT, Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
no flags Details
Firefox 52 [e10s=enabled].png (22.09 KB, image/png)
2016-10-27 23:56 PDT, Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
no flags Details
Firefox 52 [e10s=disabled].png (21.95 KB, image/png)
2016-10-27 23:56 PDT, Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.)
no flags Details

Description User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 10:02:22 PDT
STR:
1. Open this website page - https://bugzilla.mozilla.org/enter_bug.cgi?product=Core
2. Open second "Platform" dropdown menu list
3. See that visual appearance of dropdown menu list with e10s enabled is different compared to dropdown menu list with e10s disabled.

Most notable changes are that:
- font family used in foreground text isn't used in dropdown menu list
- there are too much useless space between items in dropdown menu list
Comment 1 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 10:03:57 PDT
Created attachment 8805192 [details]
e10s disabled.png
Comment 2 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 10:04:24 PDT
Created attachment 8805193 [details]
e10s enabled.png
Comment 3 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 10:05:22 PDT
Also size of the font is different.
Comment 4 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 23:54:52 PDT
[Tracking Requested - why for this release]: Regression

On stable builds the regression started in Firefox 48, where e10s is by default enabled.
Comment 5 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 23:56:11 PDT
Created attachment 8805454 [details]
Firefox 51 [e10s=enabled].png
Comment 6 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 23:56:31 PDT
Created attachment 8805455 [details]
Firefox 52 [e10s=enabled].png
Comment 7 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 23:56:50 PDT
Created attachment 8805456 [details]
Firefox 52  [e10s=disabled].png
Comment 8 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-27 23:58:13 PDT
There even was some change between Firefox 51 and Firefox 52 in this issue.
Comment 9 User image Neil Deakin (mostly unavailable until September) 2016-10-31 06:47:39 PDT

*** This bug has been marked as a duplicate of bug 1300784 ***
Comment 10 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-31 09:11:34 PDT
Bug #1300784 is only about combining e10s and non-e10s <select> dropdown mechanisms, not about regression that dropdown menu list is using wrong font family & size and have too much useless space between items.
Comment 11 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-10-31 09:15:28 PDT
Bug #1091592 probably regressed most of things stated in this bug.
Comment 12 User image Mark Golbeck 2016-10-31 10:29:35 PDT
The spacing between items was a conscious design decision.
Comment 13 User image Jared Wein [:jaws] (please needinfo? me) 2016-10-31 10:33:30 PDT
Is it a regression that the popup uses a different font-family than the button in the page? What happened before this patch if the font-family on the page was set to Georgia, for example?

As Neil commented, the difference between e10s and non-e10s will be fixed with bug 1300784.
Comment 14 User image Jim Mathies [:jimm] 2016-11-02 11:31:42 PDT
The e10s team triaged a number of bugs about this. Basically we switched UI elements for the drop down, and because of that, the fonts and layout changed somewhat. The consensus was that the new layout was better. Regardless, we decided we would not attempt to fix these issues since e10s is replacing non-e10s so minor font/layout differences in the dropdown are irrelevant.
Comment 15 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-11-02 11:48:17 PDT
What are the reasons for:
-making font smaller
-making dropdown text using other font family than on button
-increasing that much space between items, which is useless on non-touch devices
-changing appearance to be inconsistent compared to other browser?
Comment 16 User image Marcia Knous [:marcia - use ni] 2016-11-02 13:10:59 PDT
Tracking 52- based on resolution.
Comment 17 User image Gerry Chang [:gchang] 2016-11-02 23:48:15 PDT
Per comment #14, track 51-.
Comment 18 User image Jared Wein [:jaws] (please needinfo? me) 2016-11-07 07:21:42 PST
Hey Philipp, what do you think about the difference between the font being used on the button and what shows up in the popup?

You can look at https://bug1313418.bmoattachments.org/attachment.cgi?id=8805455 to see the difference. We didn't change the font on the button because we are worried about web compat.
Comment 19 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-11-08 03:08:33 PST
Please, see comment #15
Comment 20 User image Jim Mathies [:jimm] 2016-11-09 06:24:22 PST
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #15)
> What are the reasons for:
> -making font smaller
> -making dropdown text using other font family than on button
> -increasing that much space between items, which is useless on non-touch
> devices
> -changing appearance to be inconsistent compared to other browser?

As I said, we switched UI elements and so the layout changed. Feel free to file bugs on individual issues.
Comment 21 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-11-09 11:44:09 PST
OK, but I was hoping that we could omit bureaucracy and deal with these issues here... seems not. ;)
Comment 22 User image Jim Mathies [:jimm] 2016-11-10 04:11:31 PST
(In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #21)
> OK, but I was hoping that we could omit bureaucracy and deal with these
> issues here... seems not. ;)

Looks like we have newer regressions in this area due to the select styling and gpu changes, so not really the same styling issues we triaged under e10s.
Comment 23 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-11-10 08:42:46 PST
(In reply to Jim Mathies [:jimm] from comment #22)
> (In reply to Virtual_ManPL [:Virtual] - (ni? me) from comment #21)
> > OK, but I was hoping that we could omit bureaucracy and deal with these
> > issues here... seems not. ;)
> 
> Looks like we have newer regressions in this area due to the select styling
> and gpu changes, so not really the same styling issues we triaged under e10s.

I reported the GPU Process changes and regressions to select dropdown menu list (especially about these blurry and not sharp fonts in text) in bug #1315568,
but this bug wasn't about it, as it was reported before GPU Process was landed,
it's about regression from bug #1091592, which is now tracked separately as you wanted.
Comment 24 User image Ritu Kothari (:ritu) 2016-11-16 15:31:17 PST
I am assuming bug 1300784 will fix this. Too late for 49 and 50, both are wontfix now.
Comment 25 User image Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) 2016-11-24 03:16:23 PST

*** This bug has been marked as a duplicate of bug 1300784 ***

Note You need to log in before you can comment on or make changes to this bug.