Last Comment Bug 1351336 - On print preview if you drag the scrollbar up and down creates some flicker
: On print preview if you drag the scrollbar up and down creates some flicker
Status: RESOLVED DUPLICATE of bug 1251617
:
Product: Core
Classification: Components
Component: Panning and Zooming (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Kartikaya Gupta (away Jan 12-26; email:kats@mozilla.com)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-28 08:12 PDT by ovidiu boca[:Ovidiu]
Modified: 2017-03-30 07:52 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected


Attachments

Description User image ovidiu boca[:Ovidiu] 2017-03-28 08:12:02 PDT
Tested on Nightly 55.0a1(2017-03-28) with Mac OS X 10.12, Ubuntu 14.04

STR: 

1. Go to http://conorlastowka.com/book/CitationNeededBook-Sample.pdf
2. Open print preview 
3. Drag the scrollbar up and down

Expected results:

The rendering is smooth without any issues. 

Actual results: 

Some flickers appear when you move up and down the scrollbar.  

Note: 

If I turn off from about:config the apz.drag pref. everything works as expected, this behavior can be obtained if you turn off the apz.allow_checkerboarding.
Comment 1 User image Kartikaya Gupta (away Jan 12-26; email:kats@mozilla.com) 2017-03-30 06:54:13 PDT
How do you open the print preview on OS X? As far as I know we never show the Firefox print preview window on OS X, since we use the OS-provided preview tool instead.
Comment 2 User image ovidiu boca[:Ovidiu] 2017-03-30 07:23:09 PDT
Sorry, I wanted to say that is reproducible only on Ubuntu. You are right there is no print preview on OS X.
Comment 3 User image Kartikaya Gupta (away Jan 12-26; email:kats@mozilla.com) 2017-03-30 07:34:25 PDT
The flickering appears to be checkerboarding, so this is probably a dupe of bug 1251617. However I also notice that when scrolling the print preview window in Linux, the content seems to shift where it is on the preview "pages" depending on the scroll position. That's really weird. Seems to happen with and without apz.drag.enabled, and happens with wheel scrolling as well. That's probably worth a separate bug.
Comment 4 User image Kartikaya Gupta (away Jan 12-26; email:kats@mozilla.com) 2017-03-30 07:51:43 PDT
I filed https://bugzilla.mozilla.org/show_bug.cgi?id=1352083 for the other issue.
Comment 5 User image Kartikaya Gupta (away Jan 12-26; email:kats@mozilla.com) 2017-03-30 07:52:52 PDT
I'm going to dupe this to bug 1251617, which is what we're using to track checkerboarding during scrollbar drag.

*** This bug has been marked as a duplicate of bug 1251617 ***

Note You need to log in before you can comment on or make changes to this bug.