Last Comment Bug 1364532 - Consider moving the Find Bar to the top
: Consider moving the Find Bar to the top
Status: RESOLVED DUPLICATE of bug 869543
:
Product: Toolkit
Classification: Components
Component: Find Toolbar (show other bugs)
: Trunk
: Unspecified Unspecified
-- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Mike de Boer [:mikedeboer]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-05-12 11:28 PDT by mario66
Modified: 2017-05-12 15:13 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
FindBarTweak.png (96.24 KB, image/png)
2017-05-12 11:28 PDT, mario66
no flags Details

Description User image mario66 2017-05-12 11:28:33 PDT
Created attachment 8867304 [details]
FindBarTweak.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20170504112025

Steps to reproduce:

1. Visit a website
2. Open find bar


Actual results:

The find bar opens at the bottom of the page. However, all other user interface elements (tabs, address bar etc.) are at the top. This leads to unnecessary mouse paths, especially if you have the taskbar at the top of the screen, too, like in many Linux distributions. Then you should actually never have a reason to move your mouse cursor to the bottom of the screen. But also on Windows it feels quite misplaced to have the find bar at the bottom of the page.


Expected results:

The find bar should open at the top of the website, right under the address bar. And ideally, the find bar should not occupy a full line, just as much space as it actually needs. Widescreen monitors are the new standard. There you should avoid as many horizontal bars as possible. A design proposal is attached.

Basically, mirror parts of the behavior of the following addon: https://addons.mozilla.org/en-us/firefox/addon/findbar-tweak/

The reason why I report this even though there is an addon for this is that your management has decided to set everything on fire and exterminate all user interface related addons soon. Hence, I though you may be interested in providing such a feature out-of-the-box. I think this a very useful feature!
Comment 1 User image Asa Dotzler [:asa] 2017-05-12 15:13:47 PDT

*** This bug has been marked as a duplicate of bug 869543 ***

Note You need to log in before you can comment on or make changes to this bug.