Last Comment Bug 1365426 - Enable the New Localization API in Gecko
: Enable the New Localization API in Gecko
Status: NEW
:
Product: Core
Classification: Components
Component: Localization (show other bugs)
: unspecified
: Unspecified Unspecified
enhancement
P3 normal with 8 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Axel Hecht [:Pike]
Mentors:
Depends on: 1388458 1394885 1405467 1410849 1410857 1410923 1415730 1416149 1424810 1425104 1426016 1434434 1441035 1452734 1462839 1463544 1486917 1490839 1504363 1517304 1333980 1347799 1347800 1347801 1394891 1402061 1407256 1407418 1427926 1428769 1437427 1438613 1438655 1443697 1455048 1455379 1488973
Blocks: 62174 1291693 1347825
  Show dependency treegraph
Regressions:
Regressed by:
 
Reported: 2017-05-16 15:36 PDT by Zibi Braniecki [:gandalf][:zibi]
Modified: 2019-03-21 15:24 PDT (History)
18 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Zibi Braniecki [:gandalf][:zibi] 2017-05-16 15:36:41 PDT
We're planning to transition Firefox to a new localization API based on Project Fluent.

As a stepping stone for that, we'll want to land and enable the new API together with new registry for l10n resources (L10nRegistry) and new model for language packs.

The aim is to migrate away from StringBundle and DTDs, enable easy language switching and updating in the product and use Fluent Syntax for localization.
Comment 1 User image Zibi Braniecki [:gandalf][:zibi] 2017-09-21 11:38:32 PDT
I carved out a new tracking bug specifically for the soft launch of L20n - bug 1402061.

I moved the dependencies for it there.

Note You need to log in before you can comment on or make changes to this bug.