Last Comment Bug 1373327 - Sending mails from earthlink webmail account stopped working in Firefox 54
: Sending mails from earthlink webmail account stopped working in Firefox 54
Status: RESOLVED FIXED
[sitewait]
: regression, site-compat
Product: Tech Evangelism
Classification: Other
Component: Desktop (show other bugs)
: Firefox 54
: Unspecified Unspecified
-- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 1373569 (view as bug list)
Depends on:
Blocks: 1275746
  Show dependency treegraph
 
Reported: 2017-06-15 10:45 PDT by [:philipp]
Modified: 2017-06-20 09:57 PDT (History)
14 users (show)
kohei.yoshino: needinfo? (kjb1611mikeiv)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
wontfix
wontfix
wontfix
unaffected


Attachments
test form (269 bytes, text/html)
2017-06-16 15:45 PDT, Kohei Yoshino [:kohei]
no flags Details

Description User image [:philipp] 2017-06-15 10:45:16 PDT
We got a couple of user reports on sumo that sending emails from the earthlink webmail interface stopped working after the firefox 54 update & their support is apparently recommending a firefox downgrade as solution at the moment: https://mzl.la/2rvQlrF
Comment 1 User image Adam Stevenson [:adamopenweb] 2017-06-15 14:23:50 PDT
Since it's difficult to troubleshoot this without an account, I reached out by phone and was transferred to their level 3 tech support. Apparently they are getting a lot of calls about it.

Thy said there's an issue with the script on the submit button and that other buttons are still functioning normally. They suggested something has changed with the release of 54, I'll try to find out what exactly broke their script here.

The web developer, who works on this is off but will give me a call back.
Comment 2 User image [:philipp] 2017-06-15 14:29:42 PDT
maybe they could provide us with credentials for a dummy account so we can regression-test it...
Comment 3 User image Karl Dubost :karlcow 2017-06-15 16:42:25 PDT
http://twitter.com/MozWebCompat/status/875498496832323585
> Anyone from @mozilla with a Earthlink webmail account and JS-fu @FirefoxDevTools can help us with this one.
Comment 4 User image Kohei Yoshino [:kohei] 2017-06-15 19:49:10 PDT
Hi Mike, I found your Bug 1305204 Comment 3. Can you please help us solve this new issue by creating a test account for EarthLink webmail again? Thanks!
Comment 5 User image [:philipp] 2017-06-16 03:56:00 PDT
*** Bug 1373569 has been marked as a duplicate of this bug. ***
Comment 6 User image Ant 2017-06-16 08:01:42 PDT
FYI. I can help if it is easy and quick. I don't know JS script though.
Comment 7 User image Ant 2017-06-16 08:04:13 PDT
Also, v53.0.3 worked fine as I mentioned in my https://bugzilla.mozilla.org/show_bug.cgi?id=1373569 bug report.
Comment 8 User image [:philipp] 2017-06-16 10:55:15 PDT
(In reply to Ant from comment #6)
> FYI. I can help if it is easy and quick. I don't know JS script though.

if you'd have a bit of time to come up with the regression range for this problem this would be of great help - more infos at https://blog.nightly.mozilla.org/2017/06/07/using-mozregression-on-windows/
thank you
Comment 9 User image Ant 2017-06-16 13:22:50 PDT
I tried to watch its video, but had problems reading and hearing. :( So, I tried it what I could figure out. The retests took hours to finish in my slow updated 64-bit W7 VM with Firefoxes on webmail.earthlink.net:

56.0a1 (2017-06-14) = reproduced/bad

54.0.0 stable (64-bit Mac OSes El Capitan v10.11.6 and Sierra v10.12.5 MBPs; 32-bit Firefox in 64-bit W7 HPE SP1 VM) = reproduced/bad

54.0a1 (2017-02-13) = reproduced/bad
54.0a1 (2017-02-11) = reproduced/bad
54.0a1 (2017-02-10) = reproduced/bad

54.0a1:
2017-02-09 = reproduced/bad
2017-02-08 = unable to reproduce/good
  f2bccdc9 = reproduced/bad
  438b18da = unable to reproduce/good
  f4f18619 = reproduced/bad
  b28f8c1a = unable to reproduce/good  
  effda19d = reproduced/bad
  6a43afee = reproduced/bad
  ed323d0c = reproduced/bad
  17157072 = reproduced/bad
  08f0cf02 = reproduced/bad
2017-02-03 = unable to reproduce/good

53.0.3 and earlier stable versions = unable to reproduce/good

--

End of Log View:
...
2017-06-16T12:56:28: INFO : Launching c:\users\tester\appdata\local\temp\tmpx4cwc1\firefox\firefox.exe
2017-06-16T12:56:28: INFO : Application command: c:\users\tester\appdata\local\temp\tmpx4cwc1\firefox\firefox.exe -profile c:\users\tester\appdata\local\temp\tmprz4nzw.mozrunner
2017-06-16T12:56:28: INFO : application_buildid: 20170208072457
2017-06-16T12:56:28: INFO : application_changeset: 08f0cf02c96cc6c6819bc5d336c9338583aa6f21
2017-06-16T12:56:28: INFO : application_display_name: Nightly
2017-06-16T12:56:28: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2017-06-16T12:56:28: INFO : application_name: Firefox
2017-06-16T12:56:28: INFO : application_remotingname: firefox
2017-06-16T12:56:28: INFO : application_repository: https://hg.mozilla.org/integration/mozilla-inbound
2017-06-16T12:56:28: INFO : application_vendor: Mozilla
2017-06-16T12:56:28: INFO : application_version: 54.0a1
2017-06-16T12:56:28: INFO : platform_buildid: 20170208072457
2017-06-16T12:56:28: INFO : platform_changeset: 08f0cf02c96cc6c6819bc5d336c9338583aa6f21
2017-06-16T12:56:28: INFO : platform_repository: https://hg.mozilla.org/integration/mozilla-inbound
2017-06-16T12:56:28: INFO : platform_version: 54.0a1
2017-06-16T12:56:57: INFO : [Child 1144] WARNING: pipe error: 109: file c:/builds/moz2_slave/m-in-w64-000000000000000000000/build/src/ipc/chromium/src/chrome/common/ipc_channel_win.cc, line 346
2017-06-16T12:59:18: INFO : 1497643158151	addons.xpi	WARN	Exception running bootstrap method shutdown on shield-recipe-client@mozilla.org: ReferenceError: LogManager is not defined (resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///c:/users/tester/appdata/local/temp/tmpx4cwc1/firefox/browser/features/shield-recipe-client@mozilla.org.xpi!/bootstrap.js:65:3) JS Stack trace: this.shutdown@resource://gre/modules/addons/XPIProvider.jsm -> jar:file:///c:/users/tester/appdata/local/temp/tmpx4cwc1/firefox/browser/features/shield-recipe-client@bootstrap.js:65:3 < callBootstrapMethod@XPIProvider.jsm:4903:11 < observe@XPIProvider.jsm:2884:15
2017-06-16T12:59:27: INFO : Narrowed inbound regression window from [b28f8c1a, 17157072] (3 revisions) to [b28f8c1a, 08f0cf02] (2 revisions) (~1 steps left)
2017-06-16T12:59:27: DEBUG : Starting merge handling...
2017-06-16T12:59:27: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=08f0cf02c96cc6c6819bc5d336c9338583aa6f21&full=1
2017-06-16T12:59:27: DEBUG : Found commit message:
Bug 1275746 - nsNavHistory::AsciiHostNameFromHostString return empty string if host is empty r=mak

MozReview-Commit-ID: 3AKgNCXPKoU

2017-06-16T12:59:27: INFO : The bisection is done.
2017-06-16T12:59:28: INFO : Stopped


I hope it didn't record and upload anything sensitives like my e-mails and passwords!
Comment 10 User image [:philipp] 2017-06-16 13:35:41 PDT
thank you ant, all this testing happened locally on your machine - no private information recorded or even uploaded.

so it seems like bug 1275746 has introduced this behaviour. can we make earthlink aware of https://www.fxsitecompat.com/en-CA/docs/2017/urls-with-no-host-name-are-now-treated-as-invalid/ ?
Comment 11 User image Ant 2017-06-16 13:45:14 PDT
You're welcome, philipp. Please kindly let me know if you need more non-personal datas. Hopefully, not tedious and hard like this regression test. :O
Comment 12 User image Adam Stevenson [:adamopenweb] 2017-06-16 13:46:47 PDT
Thank you Ant and philipp!

As mentioned earlier, the developer responsible at Earthlink has my contact information. If we don't get a response in a few days, I'll reach back out. Setting this report as sitewait.
Comment 13 User image Ant 2017-06-16 13:49:49 PDT
OK cool. Can I go ahead and shut down and revert my VM snapshot of my hours long regression tests? 

For now, EarthLink webmailers will have to avoid the newer Firefox versions and stick with v53.0.3 and earlier and/or use other web browsers (and/or email clients). :(
Comment 14 User image Kohei Yoshino [:kohei] 2017-06-16 14:15:51 PDT
Ah so this is basically a dup of Bug 1305204 that simply backed out Bug 1275746. Bug 1275746 was re-landed to 49 after Bug 1319078 is solved, but not one has verified the fix with Earthlink webmail.
Comment 15 User image Kohei Yoshino [:kohei] 2017-06-16 14:23:16 PDT
I mean "re-landed to 54", the current release.
Comment 16 User image :Gijs 2017-06-16 15:00:20 PDT
Do we have contacts at earthlink? This would be reasonably easy to fix on their side, there's detailed information in bug 1305204. :-\

On the flip side, I have no idea how we managed to regress this again - bug 1319078 should have dealt with the issue. :-\
Comment 17 User image :Gijs 2017-06-16 15:03:06 PDT
Ah, but maybe the issue is that we no longer show UI, but form submission still fails because the input validation check is failing? (I'm just speculating, don't have access to an earthlink account.) I did think that bug 1319078 comment 0, quoting bug 1305204 comment #22, indicated that it's just the popup that chrome isn't showing... but perhaps it's also not actually validating hidden form fields? That would be... interesting...
Comment 18 User image Kohei Yoshino [:kohei] 2017-06-16 15:45:19 PDT
Created attachment 8878701 [details]
test form

Not sure about the exact code on Earthlink but this form for example won't get submitted even though the <input type="url"> is not displayed. In this way, there are several ways to hide an element, not only display:none and visibility:hidden.
Comment 19 User image brw 2017-06-16 18:24:59 PDT Comment hidden (me-too)
Comment 20 User image [:philipp] 2017-06-17 12:20:14 PDT
we had one affected user on support.mozilla.org saying that the issue apparently got solved on the server-side. could you confirm that it's working as expected for you too now (maybe after clearing the browser cache)?
Comment 21 User image brw 2017-06-17 12:26:56 PDT
Yes, seems to be ok now. Thanks!
Comment 22 User image Ant 2017-06-17 16:06:33 PDT
Ditto in my 64-bit W7 HPE SP1 VM when trying ELN's Webmail's send and save draft e-mail buttons. I am going to assume it will be fine in Macs too later on when I try them. Do I assume this is the web site that had problems with Firefox v54 web browsers?
Comment 23 User image brw 2017-06-17 16:31:12 PDT
Yep. Firefox 54 for Windows.
Comment 24 User image Ritu Kothari (:ritu) 2017-06-19 10:43:36 PDT
[Tracking Requested - why for this release]: A recent regression in 54. If we have a fix ready in time, we should consider inclusion in 54.0.1 depending on the overall risk.
Comment 25 User image Kohei Yoshino [:kohei] 2017-06-19 10:50:31 PDT
The bug has been fixed by Earthlink as per the previous bug comments and SUMO forum replies. We don't have to track this any more \o/
Comment 26 User image Gerry Chang [:gchang] 2017-06-20 07:43:24 PDT
Per comment #25, mark 54/55/56 won't fix.
Comment 27 User image Mike Taylor [:miketaylr] (55 Regression Engineering Owner) 2017-06-20 09:57:43 PDT
Thanks Ant, Kohei and Adam for helping us get this fixed! 

(Earthlink too....)

Note You need to log in before you can comment on or make changes to this bug.