Last Comment Bug 182418 - input form fields with type hidden sometimes display as empty text input fields in the page.
: input form fields with type hidden sometimes display as empty text input fiel...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Other Branch
: x86 Windows 98
-- minor (vote)
: ---
Assigned To: layout.form-controls
: Terri Preston
: Andrew Overholt [:overholt]
Mentors:
Depends on: 182500
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-27 23:11 PST by James Morgan
Modified: 2002-12-03 07:40 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
reporter's testcase (192 bytes, text/html)
2002-11-28 08:29 PST, David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-8 (if account gets disabled due to email bounces, ask a bugzilla admin to reenable it)
no flags Details

Description User image James Morgan 2002-11-27 23:11:12 PST
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2) Gecko/20021126

If an input filed with type set to hidden is not preceded by either the body
open tag or text it will be displayed as a text field, but will not have it's
default value set.

Reproducible: Always

Steps to Reproduce:
1. Save the following in a file:
<html>
<form action="/listings/update.php" method=post>
<input type=hidden name=test1 value=value1> :test1<br>
test2: <input type=hidden name=test2 value=value2><br>
 </table>
</form>
</html>

2. Load the file in Mozilla

Actual Results:  
An empty text input field apears before the test ' :test1'


Expected Results:  
the field should have been hidden and kept its value.

Workarounds are trivial, the <body> tag or any text, even a period, prior to the
hidden input will cause it to behave normaly.
Comment 1 User image Shervin 2002-11-28 07:44:44 PST
Build: Mozilla/5.0 (X11; U; Linux i686; rv:1.2) Gecko/20021126

This also happens with the above build.
Comment 2 User image David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-8 (if account gets disabled due to email bounces, ask a bugzilla admin to reenable it) 2002-11-28 08:29:18 PST
Created attachment 107710 [details]
reporter's testcase
Comment 3 User image David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-8 (if account gets disabled due to email bounces, ask a bugzilla admin to reenable it) 2002-11-28 08:30:47 PST
This is 1.2-branch only.  See bug 182500.
Comment 4 User image George Ivanov 2002-12-02 00:37:45 PST
"input form fields with type hidden sometimes display as empty text input fields
in the page."

Yes when the page has no <BODY> tag.
Comment 5 User image David Baron :dbaron: 🏴󠁵󠁳󠁣󠁡󠁿 ⌚UTC-8 (if account gets disabled due to email bounces, ask a bugzilla admin to reenable it) 2002-12-03 07:40:37 PST
I have tested that this bug was an instance of bug 182500 / bug 182253 based on
comparison of two Linux builds compiled with gcc 3.2.  This bug was present in
the 1.2 release and was the only bug fixed in the 1.2.1 release (and the reason
for the 1.2.1 release).

Marking this bug as fixed since it should be fixed in the 1.2.1 release.

Note You need to log in before you can comment on or make changes to this bug.