Last Comment Bug 195689 - Edit menu: Bad shortcut for "Fill in Form" - clash with "Find in This Page" both use "F"
: Edit menu: Bad shortcut for "Fill in Form" - clash with "Find in This Page" b...
Status: RESOLVED WORKSFORME
: access, regression
Product: Core
Classification: Components
Component: Keyboard: Navigation (show other bugs)
: Trunk
: All All
-- minor with 1 vote (vote)
: ---
Assigned To: Mats Palmgren (:mats)
:
: Andrew Overholt [:overholt]
Mentors:
: 205030 212052 213784 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-02 18:32 PST by km
Modified: 2004-08-08 11:27 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (868 bytes, patch)
2003-07-09 11:44 PDT, Mats Palmgren (:mats)
aaronlev: review-
Details | Diff | Splinter Review
Screenshot: Tools->Form Manager menu (935 bytes, image/png)
2003-07-09 16:28 PDT, Mats Palmgren (:mats)
no flags Details
Screenshot: Edit menu (3.73 KB, image/png)
2003-07-09 16:29 PDT, Mats Palmgren (:mats)
no flags Details
Patch rev. 2 (869 bytes, patch)
2003-07-10 02:10 PDT, Mats Palmgren (:mats)
aaronlev: review+
Details | Diff | Splinter Review
Screenshot: Tools->Form Manager menu (938 bytes, image/png)
2003-07-10 02:11 PDT, Mats Palmgren (:mats)
no flags Details
Screenshot: Edit menu (3.65 KB, image/png)
2003-07-10 02:12 PDT, Mats Palmgren (:mats)
no flags Details

Description User image km 2003-03-02 18:32:02 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030228
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030228

The Edit menu used to have a short cut for "Fill in Form" which was
an "m". Recently, the menu changed and now has the first F underlined.
Since there is an earlier entry "Find in Page" with the first F
also underlined, there is now no keystroke shortcut for "Fill in Form"

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 User image Evzen Polenka 2003-03-25 14:24:03 PST
I can confirm this one.
It's quite annoying, can someone fix it, please? It's been there for quite a
while  and no one seems to care.
Comment 2 User image piers 2003-03-25 15:24:14 PST
Ok, confirming this. Finding out from Netscape UE about whether we can remove
these items altogether since they are duplicated under Tools -> Form Manager ->
Fill in Form and Tools -> Form Manager -> Save Form Info.
Comment 3 User image piers 2003-03-25 15:25:17 PST
-> Keyboard Navigation
Comment 4 User image Mats Palmgren (:mats) 2003-07-08 07:49:09 PDT
This is a regression from bug 179661.  Piers, are you working on this?
This actually breaks kbd navigation for "Find in This Page".
Comment 5 User image Mats Palmgren (:mats) 2003-07-08 07:51:00 PDT
*** Bug 205030 has been marked as a duplicate of this bug. ***
Comment 6 User image Mats Palmgren (:mats) 2003-07-08 07:51:27 PDT
*** Bug 212052 has been marked as a duplicate of this bug. ***
Comment 7 User image piers 2003-07-09 04:30:13 PDT
Mats, sorry, i can't work on this at the moment. Please feel free to take the
bug.
Comment 8 User image Mats Palmgren (:mats) 2003-07-09 11:44:11 PDT
Created attachment 127364 [details] [diff] [review]
Patch

Change accesskey for "Fill in Form" from 'F' to 'i' to avoid clash in Edit menu

with "Find in This Page"
Comment 9 User image Mats Palmgren (:mats) 2003-07-09 11:49:55 PDT
Taking this...
Comment 10 User image Mats Palmgren (:mats) 2003-07-09 11:56:15 PDT
"o" is an alternative that would work also if you prefer that.
The underline under "i" is a bit tiny and hard to see perhaps, but it's
used elsewhere (Page Info) so I guess it's OK.
Comment 11 User image Dean Tessman 2003-07-09 16:04:19 PDT
<kinda offtopic> Isn't the underline for the 'I' in Page Info wider, though,
since it's a capital 'I'? </kinda offtopic>

This affects the entry under the Tools > Form Manager menu as well, right?
Comment 12 User image Mats Palmgren (:mats) 2003-07-09 16:27:16 PDT
Yes, it will change the "Fill in Form" entry in both menus.

Regarding the width, a capital 'I' has the same width as 'i' (on Linux anyway)
so the underline will be the same too.
Attaching screenshots...
Comment 13 User image Mats Palmgren (:mats) 2003-07-09 16:28:47 PDT
Created attachment 127392 [details]
Screenshot: Tools->Form Manager menu
Comment 14 User image Mats Palmgren (:mats) 2003-07-09 16:29:41 PDT
Created attachment 127393 [details]
Screenshot: Edit menu
Comment 15 User image Aaron Leventhal 2003-07-10 01:31:25 PDT
Comment on attachment 127364 [details] [diff] [review]
Patch

I'm sorry, but we do everything we can to avoid lowercase i or l as accesskeys,
because the underline is so small it's very hard to see.

Our guide for choosing accesskeys is here:
http://www.mozilla.org/projects/ui/accessibility/accesskey.html

Note that we ave some other rules, most of which we picked up from Microsoft's
UI guidelines.
Comment 16 User image Mats Palmgren (:mats) 2003-07-10 02:10:23 PDT
Created attachment 127426 [details] [diff] [review]
Patch rev. 2
Comment 17 User image Mats Palmgren (:mats) 2003-07-10 02:11:18 PDT
Created attachment 127427 [details]
Screenshot: Tools->Form Manager menu
Comment 18 User image Mats Palmgren (:mats) 2003-07-10 02:12:18 PDT
Created attachment 127428 [details]
Screenshot: Edit menu
Comment 19 User image Aaron Leventhal 2003-07-10 03:02:15 PDT
Comment on attachment 127426 [details] [diff] [review]
Patch rev. 2

Great. Thanks for doing this.
Comment 20 User image Jo Hermans 2003-07-24 16:53:56 PDT
*** Bug 213784 has been marked as a duplicate of this bug. ***
Comment 21 User image Daniel Convissor 2004-03-04 14:24:40 PST
Loaded up the 2003030309 nightly build dated and this bug has been fixed. 
Please mark it as fixed.  Thanks.
Comment 22 User image Mats Palmgren (:mats) 2004-08-08 11:27:02 PDT
Someone else has already fixed this...

-> WORKSFORME

Note You need to log in before you can comment on or make changes to this bug.