Note: There are a few cases of duplicates in user autocompletion which are being worked on.
Last Comment Bug 197530 - Removal of PPM support
: Removal of PPM support
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: x86 Linux
-- normal (vote)
: ---
Assigned To: tor
: Terri Preston
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-15 04:51 PST by tor
Modified: 2003-06-06 10:55 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
ppm removal (30.68 KB, patch)
2003-03-15 04:52 PST, tor
pavlov: review+
blizzard: superreview+
Details | Diff | Splinter Review

Description User image tor 2003-03-15 04:51:07 PST
PPM was a handy simple image format for testing when libpr0n was being
written, but has now outlived its time in the mozilla tree.  Removal
gains us about 5K on linux.
Comment 1 User image tor 2003-03-15 04:52:02 PST
Created attachment 117314 [details] [diff] [review]
ppm removal
Comment 2 User image Boris Zbarsky [:bz] 2003-03-15 08:20:04 PST
Doesn't biesi's work to make decoders completely pluggable largely obviate these
changes (except the build system ones?).
Comment 3 User image Christian :Biesinger (don't email me, ping me on IRC) 2003-03-15 08:47:10 PST
no... they are not yet completely pluggable... most importantly, the image
mimetype sniffing (in imgLoader.cpp) is not pluggable yet...
Comment 4 User image tenthumbs 2003-03-15 09:23:38 PST
Well, it doesn't actually work anyway although mozilla recognizes the 
mime type so it's probably not a loss. However, it _is_ a common unix 
format do platform parity rather demands that you also remove bmp 
support as well.

Note that on Linux plugins are rather wedged with respect to large 
objects so it may not be possible to view such an image even with a 
plugin.
Comment 5 User image Christian :Biesinger (don't email me, ping me on IRC) 2003-03-15 10:42:45 PST
PPM works for me at http://gemal.dk/browserspy/images.html. Directly loading
http://gemal.dk/browserspy/pics/test.ppm also works for me.
Comment 6 User image tenthumbs 2003-03-15 12:24:53 PST
Yes, but mozilla doesn't understand the generic anymap (.pnm) form. Apache does
so it sends image/x-portable-anymap which confuses mozilla. Because I often use
my own server to view the file system I see this a lot.
Comment 7 User image hacker formerly known as seawood@netscape.com 2003-03-18 10:56:09 PST
Comment on attachment 117314 [details] [diff] [review]
ppm removal

r=cls on the build changes
Comment 8 User image Stuart Parmenter 2003-03-18 14:06:43 PST
Comment on attachment 117314 [details] [diff] [review]
ppm removal

r=pavlov
Comment 9 User image Christopher Blizzard (:blizzard) 2003-04-24 09:44:53 PDT
Comment on attachment 117314 [details] [diff] [review]
ppm removal

rs=blizzard
Comment 10 User image Jason Mobarak 2003-05-11 12:58:28 PDT
Using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla
Firebird/0.6

when viewing:

http://www.unm.edu/~jmob/images/io.ppm

Colors are switched (i.e. it looks like the red and blue values are switched).
Comment 11 User image tor 2003-05-31 03:54:03 PDT
Checked in.

Note You need to log in before you can comment on or make changes to this bug.