Last Comment Bug 218956 - [border-collapse] right side of page cut off, scroll bar does not scroll far enough to display edge.
: [border-collapse] right side of page cut off, scroll bar does not scroll far ...
Status: RESOLVED WORKSFORME
: testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 All
-- normal (vote)
: ---
Assigned To: layout.tables
: Madhur Bhatia
: Jet Villegas (:jet)
Mentors:
http://www.colbsa.org
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 10:15 PDT by Eileen Carpenter
Modified: 2008-10-15 21:58 PDT (History)
2 users (show)
mats: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Testcase (699 bytes, text/html)
2003-09-11 18:10 PDT, Mats Palmgren (vacation - back in August)
no flags Details

Description User image Eileen Carpenter 2003-09-11 10:15:54 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030909
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030909

I don't know if it is a table problem, but the page does use a table.
It also doesn't happen every time, and I can't figure out what makes it happen
and what prevents it.

Reproducible: Sometimes

Steps to Reproduce:
1. type www.colbsa.org into browser address window
2.
3.

Actual Results:  
right side of page is cut off. Scroll bar at bottom goes part way over but still
cuts off part of page.

Expected Results:  
scroll farther over.
Comment 1 User image Mats Palmgren (vacation - back in August) 2003-09-11 18:10:52 PDT
Created attachment 131288 [details]
Testcase
Comment 2 User image Mats Palmgren (vacation - back in August) 2003-09-11 18:19:00 PDT
Confirming bug, 2003-09-11-05 trunk Linux.

Only occurs for border-collapse:collapse and forcing an early reflow using
"Hyatt's nifty trick":
http://weblogs.mozillazine.org/hyatt/archives/2003_08.html#003963
Comment 3 User image Eileen Carpenter 2003-10-22 11:28:33 PDT
This still happens.  It seems related to the size of the table at the bottom of
the page -- it will only scroll far enough left to include that table, even if
the table farther up the page is cut off.  If you click through, then go back to
it using the "back" button, it will display correctly!
Comment 4 User image Bernd 2008-10-15 21:44:37 PDT
Mats this looks like wfm with current trunk
Comment 5 User image Mats Palmgren (vacation - back in August) 2008-10-15 21:58:04 PDT
Yes, wfm too.  Could you please flag the bugs you resolve with in-testsuite?
when there is testcase attached to the bug?  I think it would be valuable to
add these as reftests because they are often edge cases and it makes sure we
have good code coverage in the tests.  (Or even better, make a reftest and
just check it in ;-) )

Note You need to log in before you can comment on or make changes to this bug.