Last Comment Bug 228191 - Java plugin fails to load in 1.6b (LoadPlugin: failed to initialize shared library)
: Java plugin fails to load in 1.6b (LoadPlugin: failed to initialize shared li...
Status: RESOLVED DUPLICATE of bug 227867
:
Product: Core Graveyard
Classification: Graveyard
Component: Java: OJI (show other bugs)
: Trunk
: x86 Linux
-- major (vote)
: ---
Assigned To: general
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-11 10:44 PST by Kees Kuip
Modified: 2010-10-16 12:24 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Kees Kuip 2003-12-11 10:44:29 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6a) Gecko/20031029
Build Identifier: Mozilla 1.6b


Mozilla is not able to load the java plugin.
Here's the message :

LoadPlugin: failed to initialize shared library
/usr/local/program/java/j2sdk1.4.2/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
[/usr/local/program/java/j2sdk1.4.2/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so:
undefined symbol: _ZdlPv]


The plugin is linked in ~/.mozilla/plugins.
The same directory is used for mozilla1.6a and there it works fine.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
Mozilla starts but java won't work
Comment 1 User image Kevin Chen 2003-12-11 11:18:10 PST
Confirming bug.  I see it on 2003120809 (1.6b) on Linux.  (In my case, the
plugin is in /usr/local/mozilla/plugins instead of ~/.mozilla/plugins)
Comment 2 User image Mitch 2003-12-11 14:39:11 PST
I'm using the Java plugin on a Linux box no problem and todays 1.6b mozilla
build. Are you using a precompiled nightly build or compiling it yourself ?
Comment 3 User image Olivier Cahagne 2003-12-11 15:17:49 PST
It looks like 1.6b and the 1209 nightly were built using gcc 2.96 rather than
3.2.
Can you test this build instead ?
http://mozilla.oregonstate.edu/pub/mozilla.org/mozilla/tinderbox-builds/comet/

*** This bug has been marked as a duplicate of 227867 ***

Note You need to log in before you can comment on or make changes to this bug.