Last Comment Bug 275871 - View > Sort By > Grouped by Sort keyboard shortcut goes against interface guidelines (back out bug 263919, remove G shortcut)
: View > Sort By > Grouped by Sort keyboard shortcut goes against interface gui...
Status: VERIFIED FIXED
: access
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All All
-- minor with 1 vote (vote)
: Thunderbird 3.0b1
Assigned To: Bryan Clark (DevTools PM) [:clarkbw]
:
:
Mentors:
: 420096 457637 459821 (view as bug list)
Depends on: 263919 549990
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-23 17:00 PST by Aaron Ballman
Modified: 2011-03-22 20:17 PDT (History)
15 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
remove the single key G shortcut to group sort by [Checkin: Comment 19] (4.88 KB, patch)
2008-10-01 12:20 PDT, Bryan Clark (DevTools PM) [:clarkbw]
philringnalda: review+
Details | Diff | Splinter Review

Description User image Aaron Ballman 2004-12-23 17:00:01 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0 StumbleUpon/1.999

In human interface guidelines for all major platforms (Windows, Gnome, KDE,
Apple), you should never use a single printable character as a keyboard
shortcut.  It is too easy to mistakenly hit!  Even worse, once you have turned
Grouped by Sort on (especially when accidental), there's no shortcut to set any
of the other sort options (like Threaded or Unthreaded).

If you must use a shortcut for items in a group, it would be nice to have a
shortcut for all items in the group.  But even better (IMHO) would be to make
the shortcut use a modifier key such as Ctrl as well.

Reproducible: Always

Steps to Reproduce:
1. Go into message view
2. Bump the "G" key  ;-)
3.

Actual Results:  
Performs as expected and does the Grouped sort.  In this regard, it's working great.

Expected Results:  
The shortcut (if any is truly needed) should have a modifier included to meet
HIG standards.
Comment 1 User image Mike Cowperthwaite 2004-12-24 09:02:13 PST
Moz/TB does have several single-character shortcuts, but they have to date been 
used for message operations.  Having a single letter (in fact, having *any* 
shrotcut) for a change to the view is unprecedented; it is also asymmetric, 
since there is no similar means to get *out* of grouped mode (into either 
threaded or unthreaded).  I agree with reporter that this shortcut is ill-
conceived and should be rolled back.

xref bug 263571
Comment 2 User image Henrik Skupin (:whimboo) 2004-12-29 13:10:37 PST
Shortcuts are a feature to get faster access to often used functions. Switching
between "normal" and grouped view isn't used so often to give it a shortcut! We
should carefully decide which features should be accessible over shortcuts and
which not. IMO this one doesn't need any shortcut.
Comment 3 User image Tom Blake 2005-01-05 15:07:03 PST
When attempting to search messages, using the search field, certain letters
simply cannot be used, as they activate shortcuts!  This is terribly annoying!
Comment 4 User image David Grant 2005-02-12 13:12:59 PST
We need a shortcut for Grouped sort. Why? Because with the current
functionality, switching from "sort by date/grouped" to "sort by subject"
removed grouping. Then going back to sorting by date, and grouped is removed. I
need to have the quick ability to get grouped sorting back once it's lost. If
grouping stayed on like it should, when switching between subject and date or
vice versa, then removing the keyboard shortcut is fine.

Whether it's CTRL-G or G I don't care. By the way, just pressing G doesn't work
for me in Linux.

Tom Blake I don't understand your statement and I believe it to be 100% wrong.
When searching in the search field it gets the focus and no message single-key
shortcuts work. For example, importance levels: 1, 2, 3, 4, 5, and read: "m",
threaded/unthreaded: "*" and "/" all work in the search field and don't affect
the displaying of messages in Thunderbird 1.0.
Comment 5 User image xolaware.llc 2005-02-20 19:26:52 PST
in reference to <a href=https:show_bug.cgi?id=275871#c4>comment 4</a>, the "100%
wrong" part hasn't attempted to search with something with the letter 'g' in it.
 at least on macos using thunderbird version 1.0.1 (20050219), even though all
the single character items that work on individual messages do not cause
problems, 'g' does.  when entering it, my View menu flashes, indicating to me
that it is trying to perform that operation.  my recommendation would be on
macos to use Cmd-Opt-G, and for other platforms, Meta-G of one sort or another.
 (fwiw, i do find having a key shortcut for this useful, so i don't want the
key-shortcut to go away, just not to conflict with the search-bar.)
Comment 6 User image Ihar 'Philips' Filipau 2005-06-06 07:27:01 PDT
Just to state shortly: I need some shortcut to bring view into the same state as
it was before.

In other words: right now 'G' behaves as "switch grouping on", instead of more
logical and more useful "toggle grouping".

When I read message board anouncments I use 'T' very much/often/fast and it is
quite painful when finger slip to 'G': then I have to locate my mouse on table,
locate mouse cursor on screen; locate menu bar of Tb; try to recall how to turn
this off; fail; try again; fail; spend five minutes to dig thru bunch of menus
to locate what is assigned to 'G', etc.

Toggling I think will satisfy all interested partie: who want to have a shortcut
for grouping and who hit 'G' accidently. Guidlines people can be safely ignored
- after all this is usability/utility matter ;-)

P.S. Or do it like it is done in Mac OS X: additional option to activate so
called keyboard access. Not much people use it, newbies all the time gets
confused by it when they press something on keyboard accidently. But people like
I'm (who consider everyone using mouse a [CENSOREDx3]) do use that functionality
all the time. This way, designing applications one can make even more shortcuts.
Or again how it is done in Mac OS X - provide a check list with shortcuts,
allowing user to activate/deactivate/modify every shortcut for particular window.
Comment 7 User image Ihar 'Philips' Filipau 2005-06-06 07:31:00 PDT
Oh yeah. Additionally it would be lovely that after toggling, Tb will restore
view precisely as it was before. For now it always jumps to the top of the list.
For example I normally sort message list so that new messages appear on bottom:
that way I always read mail in order it has arrived.
Comment 8 User image Frankie 2005-09-21 06:22:06 PDT
this key binding (and all others like it) impacts on bug 199019, but is not
explicitly a blocker.
Comment 9 User image Geir Johansen 2007-11-01 16:02:38 PDT
I accidentally hit the 'G' key and it took me awhile to figure what happen until I found this bug.  The 'G' shortcut is NOT documented in http://www.mozilla.org/support/thunderbird/keyboard!!
Comment 10 User image Henrik Skupin (:whimboo) 2007-11-05 13:03:57 PST
Aaron what do you feel about this bug?
Comment 11 User image Aaron Leventhal 2007-11-05 19:21:39 PST
I personally like many of the single letter shortcuts in Thunderbird, and I think taking them away would make many users upset. HIG are guidelines not laws right?

That said, using G may be obscure here. I don't have a strong opinion although one thing I would say -- in the menu the G is drawn too close to the menu item so I didn't even realize it was a shortcut until I was pointed to this bug.
Comment 12 User image Ihar 'Philips' Filipau 2007-11-05 23:48:43 PST
To me, there is no problem with single letter shortcut at all.

My problem is that shortcut does something, what can't be undone as easily as it was done.

I use all the day 't' shortcut to go through automated notification or RSS feeds. Now and then finger misses 't' and hits 'g'. Since it is not a toggle shortcut, undoing what 'g' does to my actual folder view is nontrivial.
Comment 13 User image Henrik Skupin (:whimboo) 2007-11-06 05:52:10 PST
(In reply to comment #11)
> That said, using G may be obscure here. I don't have a strong opinion although
> one thing I would say -- in the menu the G is drawn too close to the menu item
> so I didn't even realize it was a shortcut until I was pointed to this bug.

To close inside the menu is even better as to see nothing. Especially on Mac OS X all the single key shortcuts aren't listed inside the menu. You won't recognize them. But I think that is another (already existing) bug? Aaron, you are familar with that?

There is bug 263571 which handles the improvement of switching between the different views.

Which person we have to ping to update the mozilla.org website?
Comment 14 User image Gary Kwong [:gkw] [:nth10sd] 2008-04-21 20:52:59 PDT
*** Bug 420096 has been marked as a duplicate of this bug. ***
Comment 15 User image Joshua Cranmer [:jcranmer] 2008-09-29 04:52:02 PDT
*** Bug 457637 has been marked as a duplicate of this bug. ***
Comment 16 User image Bryan Clark (DevTools PM) [:clarkbw] 2008-10-01 12:20:48 PDT
Created attachment 341322 [details] [diff] [review]
remove the single key G shortcut to group sort by
[Checkin: Comment 19]

The problem here isn't the lack of undo for this option, it's that an option like this shouldn't be on a single keyboard shortcut.  Single keyboard shortcuts should be reserved for the operations that people do most while using Thunderbird, navigate and process messages are those things.  Changing views, especially in this manner does not make sense.

While it should be easier to swap in and out of view types, that is a separate bug for making a better view system; this bug is about making peoples lives easier and reclaiming a keyboard shortcut.
Comment 17 User image Phil Ringnalda (:philor) 2008-10-14 08:36:31 PDT
Comment on attachment 341322 [details] [diff] [review]
remove the single key G shortcut to group sort by
[Checkin: Comment 19]

Yeah, accidental invocation with a hair-trigger probably isn't the best way to introduce people to a feature :)
Comment 18 User image Phil Ringnalda (:philor) 2008-10-14 08:43:02 PDT
*** Bug 459821 has been marked as a duplicate of this bug. ***
Comment 19 User image Serge Gautherie (:sgautherie) 2008-10-14 11:40:23 PDT
Comment on attachment 341322 [details] [diff] [review]
remove the single key G shortcut to group sort by
[Checkin: Comment 19]

http://hg.mozilla.org/comm-central/rev/f52e5992b2aa
Comment 20 User image Mike Cowperthwaite 2008-11-28 11:54:47 PST
I know this is a puny little bug that has no implications beyond UE, but: I'm unlikely to switch to 3.0 because bug 459521 is unlikely to be fixed for that build.  But I would *really* like this patch (or its equivalent) in a 2.0.x release.  It's tiny.  Please?
Comment 21 User image Henrik Skupin (:whimboo) 2008-11-28 14:13:21 PST
Verified with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b2pre) Gecko/20081027 Shredder/3.0b1pre.

Thanks for removing this useless shortcut.
Comment 22 User image Wayne Mery (:wsmwk, NI for questions) 2009-01-24 07:48:12 PST
Threadkey extension restores this functionality with G, T, and U keys
 http://threadkey.mozdev.org/drupal/
Comment 23 User image Thomas D. (currently busy elsewhere; needinfo?me) 2011-01-15 15:46:52 PST
http://gsfn.us/t/1m0de - 
grouped by sort shortcut not Working in TB 3.1.4
Comment 24 User image Wayne Mery (:wsmwk, NI for questions) 2011-03-22 20:17:41 PDT
1.8 is no longer being built, so removing request for 1.8

Note You need to log in before you can comment on or make changes to this bug.