Last Comment Bug 280244 - Can't delete characters correctly
: Can't delete characters correctly
Status: RESOLVED WORKSFORME
:
Product: SeaMonkey
Classification: Client Software
Component: Composer (show other bugs)
: Trunk
: x86 All
-- normal (vote)
: ---
Assigned To: composer
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-28 12:44 PST by Tomoo Nomura
Modified: 2005-10-02 17:39 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
dample html for incorrect deletion (327 bytes, text/html)
2005-01-28 12:46 PST, Tomoo Nomura
no flags Details

Description User image Tomoo Nomura 2005-01-28 12:44:07 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041217

When deleting a character which locates before the cursor, the editor deletes a
character which locates two before the cursor incorrectly.

Reproducible: Always

Steps to Reproduce:
1. save attached file as compo1.html
2. launch composer and open compo1.html
3. locate the cursor after the character "2004"
4. delete the character "4" of "2004" by pressing Backspace key.
5. You will see the strings "204".
Actual Results:  
It deletes the character "0".

Expected Results:  
It must delete the character "4".
Comment 1 User image Tomoo Nomura 2005-01-28 12:46:50 PST
Created attachment 172728 [details]
dample html for incorrect deletion
Comment 2 User image zug_treno 2005-03-17 09:13:42 PST
I can reproduce this bug with Mozilla 1.8b1 and the attached testcase.
Comment 3 User image Gervase Markham [:gerv] (not reading bugmail) 2005-09-27 01:54:47 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 4 User image Tomoo Nomura 2005-09-27 19:16:26 PDT
It seems to be fixed in Seamonkey 1.1a Gecko/20050923 Linux.
Please close it.
Comment 5 User image Gérard Talbot 2005-10-02 17:39:40 PDT
Resolving as WORKSFORME per reporter's comment.

Note You need to log in before you can comment on or make changes to this bug.