Last Comment Bug 281308 - renaming POP server may rename account-name
: renaming POP server may rename account-name
Status: RESOLVED DUPLICATE of bug 720199
:
Product: Thunderbird
Classification: Client Software
Component: Account Manager (show other bugs)
: unspecified
: x86 Windows XP
-- minor (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 720199
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-06 14:36 PST by L A Walsh
Modified: 2012-06-06 23:12 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image L A Walsh 2005-02-06 14:36:01 PST
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
Build Identifier: version 1.0 (20041206)

I have 20-30 bogus POP accounts defined with bogus server names to enable 
me to send email from multiple addresses (though email to those addresses
all gets funneled into 1 ISP mail account).  For most of these I used
one character server names.  I decided to go through and rename them
all to a valid server name "mail" and had a surprise:
Any "account name" that had the same character I'd used for the original
servername had each occurance of that character in the "account name"
replaced with the new server name ("mail").

Reproducible: Always

Steps to Reproduce:
1. create POP account paralight@aol.com, use servername "a" (setup server to 
not download messages automatically, since messages will never be downloaded 
for this account -- it is purely created to allow an alternate "From" address,
in this case, when dealing with a company called "Paralight"; should accept 
default username of paralight, and default emailname of "paralight@aol.com".
2. After all is setup, go in and change the servername from "a" to "mail" 
3.

Actual Results:  
The "Account name" under account settings and in the account/folder display
pane is set to "pmailrmaillight@mailol.com".  Note each occurance of the
servername in the orginal account name is replaced with the new servername.

Expected Results:  
I'd expect the account name to be unchanged after changing the server setting.


Work-around is to manually go through all affected accounts and reset
the account name to it's original name.

This is just a weird side effect.
Comment 1 User image Albert Feller 2005-03-22 16:42:30 PST
I can reproduce this bug with 1.0.2 and 2005-03-21-05-trunk on Windows XP
Comment 2 User image :aceman 2012-02-23 08:56:15 PST
This seems to be very similar to bug 720199. This is actually a feature, however it assumes the old server name string will be found only once in the account name :)

Note you can probably use the Identities feature on your main account to setup for the use case you described.
Comment 3 User image Jens Hatlak (:InvisibleSmiley) 2012-02-23 09:00:34 PST
(In reply to :aceman from comment #2)
> This seems to be very similar to bug 720199

Don't be afraid to say "dupe". ;-)

Actually I think this should be solved in such a way that only a "<user>@<server>" account name is updated by a user name change, and for safety check that both the old and new user name are non-empty (which I guess is the cause for bug 720199).
Comment 4 User image :aceman 2012-02-23 09:05:28 PST
That bug was about the 'username' so it is slightly different. But yes, the fix should take both fields with one shot ;)

Good proposal, post it into 720199 and I can work on it, if the mangling is in the account manager's JS code.
Comment 5 User image :aceman 2012-05-24 03:23:59 PDT
So now bug 720199 has landed and it handles both username and hostname in the account name.
So let's dupe this.
L A Walsh, if you still find your problem is happening in recent Thunderbird (15+) then reopen this bug.

*** This bug has been marked as a duplicate of bug 720199 ***
Comment 6 User image L A Walsh 2012-06-06 20:23:09 PDT
Why wasn't the newer bug duped to the older bug?


It seems this problem has been around for 7 years, and now someone else reports it and it gets attention, and this gets closed as a dup of it??!?!

ARG!!!

Ya know, it's really true a woman says something, it gets ignored, but a man comes along and says the same thing and it gets fixed...

As for finding out if it is happening in TB15+...it's not like I go out of my way to break my email ..... ('sides, still running TB2... & FF3.6)....   ;-)



I've hit the higher numbered releases on my linux machine...am waiting for the 64-bit releases on Windows to become officially supported...that would force me to upgrade...
Comment 7 User image :aceman 2012-06-06 23:12:31 PDT
Sorry about that, it is just coincidence which bug gets more attention.
Usually bugs should be duped to the older bug. But in this case the other (newer) bug had more context and analysis so it was decided to do the work and fix there.

But the most important thing is that any of the bugs is fixed finally. You can wait until TB15 final is released in 3 months, no problem with that.

AND from the nicks here it is not possible to know who is a woman, so we could not ignore them even if we wanted to:)
BUT we do not want! Great to see a woman in bugzilla. Thanks for filing bugs!

(And as I said, try to use Identities instead of full accounts, it may make your account tree cleaner :))

Note You need to log in before you can comment on or make changes to this bug.