Last Comment Bug 290146 - overflow: hidden block not wrapped past float when containing block too narrow
: overflow: hidden block not wrapped past float when containing block too narrow
Status: RESOLVED DUPLICATE of bug 478834
: testcase
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: All All
-- normal with 2 votes (vote)
: mozilla42
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://www.hixie.ch/tests/adhoc/css/b...
: 295069 350474 400709 756667 1048779 (view as bug list)
Depends on: 105520
Blocks: css2.1-tests
  Show dependency treegraph
 
Reported: 2005-04-13 03:29 PDT by Hixie (not reading bugmail)
Modified: 2015-08-06 22:19 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Hixie (not reading bugmail) 2005-04-13 03:29:58 PDT
STEPS TO REPRODUCE
1. Have a block of width 2x.
2. Put a float inside it of width x.
3. Put an overflow:hidden block inside the block of width x+1.

EXPECTED RESULTS
   overflow:hidden block under float.

ACTUAL RESULTS
   overflow:hidden block next to float.

TESTCASE
http://www.hixie.ch/tests/adhoc/css/box/float/root-formatting-contexts/001.html
Comment 1 User image djpohly 2005-05-22 06:21:57 PDT
*** Bug 295069 has been marked as a duplicate of this bug. ***
Comment 2 User image Boris Zbarsky [:bz] (if a patch has no decent message, automatic r-) 2006-11-03 07:36:54 PST
*** Bug 350474 has been marked as a duplicate of this bug. ***
Comment 3 User image Boris Zbarsky [:bz] (if a patch has no decent message, automatic r-) 2007-10-22 12:13:45 PDT
*** Bug 400709 has been marked as a duplicate of this bug. ***
Comment 4 User image Boris Zbarsky [:bz] (if a patch has no decent message, automatic r-) 2007-10-22 12:14:21 PDT
When we check in the fix + tests, we should check "auto" in addition to "hidden" for the overflow value.
Comment 5 User image David Baron :dbaron: ⌚️UTC-7 2010-10-15 13:23:18 PDT
I think this has been mostly fixed.  However, this particular testcase still shows the problem, because for some reason the fix isn't working when the replaced element or element with overflow:hidden is at the very top of the block.
Comment 6 User image Mats Palmgren (:mats) 2012-05-19 01:59:31 PDT
*** Bug 756667 has been marked as a duplicate of this bug. ***
Comment 7 User image Mats Palmgren (:mats) 2014-08-20 15:41:09 PDT
*** Bug 1048779 has been marked as a duplicate of this bug. ***
Comment 8 User image David Baron :dbaron: ⌚️UTC-7 2015-08-06 22:19:00 PDT
Fixed by bug 478834.

*** This bug has been marked as a duplicate of bug 478834 ***

Note You need to log in before you can comment on or make changes to this bug.