Last Comment Bug 31417 - Chromes on the Mac should use Geneva, not Helvetica
: Chromes on the Mac should use Geneva, not Helvetica
Status: VERIFIED DUPLICATE of bug 16729
: platform-parity
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: PowerPC Mac System 8.5
P3 normal (vote)
: Future
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Matthew Paul Thomas
:
Mentors:
: 33180 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-10 16:15 PST by Pierre Saslawsky
Modified: 2008-10-22 01:23 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Pierre Saslawsky 2000-03-10 16:15:49 PST
Waiting for bug 3371 and bug 16729 to be fixed, would it be possible to have the 
chromes on the Mac displayed in Geneva instead of Helvetica? All the Mac 
applications use Geneva.
Comment 1 User image Pierre Saslawsky 2000-03-10 16:16:54 PST
CCd shuang. Reassigned to ben who owns the UI.
Comment 2 User image Ben Goodger (use ben at mozilla dot org for email) 2000-03-22 21:40:22 PST
not a priority, pushing out as far as possible.
Comment 3 User image Matthew Paul Thomas 2000-03-25 07:10:53 PST
*** Bug 33180 has been marked as a duplicate of this bug. ***
Comment 4 User image Matthew Paul Thomas 2000-03-25 07:18:36 PST
From bug 33180:
|
| The Mozilla UI on Mac looks *vastly* better if, in
| chrome/global/skin/default/global.css, the font-family property for `window' is 
| changed from
|   3mm Arial,Helvetica,sans-serif;
| to
|   font: 10px Geneva,sans-serif;
|
| Menus look much better, dialogs look much better, and the UI as a whole looks
| decidedly more Mac-like. There are a few minor side effects -- the Open Windows 
| button needs to be widened (or fixed so that its width is dynamic), and some
| lines of text in prefs panels are shown not to wrap properly with the slightly
| wider text. But these could probably be fixed quite quickly.
|
| I strongly suggest this crude hack be implemented as a temporary measure until 
| 3371 and 16729 are fixed, as it will curb some (not all, but some) of the wrath 
| vented by Mac users when they try Netscape beta 1.

I'm removing the milestone from this, as Ben seems not to have realized what this 
bug is for. The point of this bug is not to be implemented eventually; the point 
is for it to be implemented *now*, temporarily for beta, while we're waiting for 
3371 and 16729 -- so that Mac users find the beta more palatable than they 
otherwise would.
Comment 5 User image Pierre Saslawsky 2000-03-25 12:20:14 PST
3371 is fixed. This bug is now blocked by bug 16729.
Comment 6 User image Pierre Saslawsky 2000-03-25 13:06:09 PST
I'm afraid it's too late for the beta even if you do the job this week-end. You 
can still try, based on what you saw in bug 33180, and I'll certainly push in 
that direction if you come up with some Geneva chromes but it will be really 
difficult to get the approval to check it in on the beta branch.

I thought about blaming Ben for the situation because he's not really a Mac guy 
and that made him an excellent scapegoat but I realized it would be extremely 
unfair: we should have done it within the Mac team several months ago already. On 
the up side, the ugly helvetica look makes it very clear that it's still a 
product in the works... And in a couple of months, they will all have such a nice 
surprise when they see beta2 with Aqua or Aphrodite.
Comment 7 User image Matthew Paul Thomas 2000-03-26 09:55:33 PST
In that case, this bug should probably be WONTFIXed, since it was intended just 
for beta, and since in the long term a superior solution (using the actual system 
font, whether it is Geneva or something else) will happen automatically as Ben 
goes through the chrome fixing bug 16729.
Comment 8 User image Pierre Saslawsky 2000-03-27 16:42:40 PST
Correct: if Ben promises to fix bug 16729 for beta2, we can close this one as 
WontFix.
Comment 9 User image Ben Goodger (use ben at mozilla dot org for email) 2000-04-01 18:32:56 PST
pierre, I tried using system fonts on Mac using a recent (2 day old - after 
your system font checkin) mozilla build and found that they didn't work ;) I'm 
using MacOS8.6...

IE5/Mac managed to do them though, so I assume I have a version of MacOS capable 
of providing this information... 
Comment 10 User image Pierre Saslawsky 2000-04-10 16:59:40 PDT
ben, it works for me. To verify:
- Open the Appearance Control Panel
- Under the Fonts panel, set the Views font to Monaco 12
- Go to http://bugzilla.mozilla.org/showattachment.cgi?attach_id=6933 (it's the 
testcase under bug 3371)
==> You can see that the 'icon' and 'list' fonts are in Monaco 12, the Standard 
font is whatever you currently have in the Mozilla prefs as Serif font, and all 
the other fonts ('caption', 'menu' etc...) are in Geneva 10 which is the Small 
System font as listed (but non-modifiable) under the Appearance Control Panel.
Comment 11 User image Eli Goldberg 2000-04-26 09:19:24 PDT
QA Assigning non-confidential New/Assigned User Interface: Design Feedback bugs 
to Matthew Thomas (mpt@mailandnews.com).

Matthew Thomas is now the QA owner for the User Interface: Design Feedback 
component. (Bugs that involve UI issues in the Netscape-branded Mozilla browser 
should continue be QA assigned to elig@netscape.com.)
Comment 12 User image Matthew Paul Thomas 2000-04-29 07:42:03 PDT
Ben, if (a) Pierre's instructions work for you, and (b) you can fix bug 16729 
before beta 2, then please mark this bug as wontfix.

Removing dependency on bug 16729: this bug isn't dependent on 16729, it would be 
made obsolete by 16729.
Comment 13 User image Matthew Paul Thomas 2000-05-08 15:30:34 PDT
If this is timetabled for `Future', it's irrelevant. This was intended as a 
temporary measure only.


*** This bug has been marked as a duplicate of 16729 ***
Comment 14 User image Pierre Saslawsky 2000-05-08 17:11:41 PDT
I confirm that I opened this bug as a temporary measure.
Verified dup.

Note You need to log in before you can comment on or make changes to this bug.