Last Comment Bug 320510 - Canvas renders gif image with mask incorrectly
: Canvas renders gif image with mask incorrectly
Status: RESOLVED WORKSFORME
:
Product: Core
Classification: Components
Component: Canvas: 2D (show other bugs)
: Trunk
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan] (PTO through 8/30)
Mentors:
http://pg.photos.yahoo.com/ph/ehammer...
: 330478 332454 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-12-16 01:59 PST by Eric Hammervold
Modified: 2007-10-29 13:54 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
image for testcase (2.03 KB, image/gif)
2005-12-22 12:39 PST, Peter van der Woude [:Peter6]
no flags Details
testcase (627 bytes, text/html)
2005-12-22 12:40 PST, Peter van der Woude [:Peter6]
no flags Details

Description User image Eric Hammervold 2005-12-16 01:59:43 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051215 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051215 Firefox/1.6a1

When inserting an gif image with a transparency mask canvas renders the mask incorrectly, it looks as though it is inverting the x-axis starting point of the mask and the edges of the image are displayed in a jagged sissor pattern.

Reproducible: Always

Steps to Reproduce:
1. var testimg = new Image();
2. testimg.src = "images/test.gif";
3. ctx.drawImage(testimg,50,50,214,214);
Comment 1 User image Peter van der Woude [:Peter6] 2005-12-16 10:40:21 PST
attach testcase please
Comment 2 User image Peter van der Woude [:Peter6] 2005-12-22 12:39:08 PST
Created attachment 206634 [details]
image for testcase

testcase next
Comment 3 User image Peter van der Woude [:Peter6] 2005-12-22 12:40:42 PST
Created attachment 206635 [details]
testcase
Comment 4 User image Peter van der Woude [:Peter6] 2005-12-22 12:41:21 PST
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051220 Firefox/1.6a1 ID:2005122023

Confirmed
->New
Comment 5 User image Erryn Pollock 2006-03-14 09:56:08 PST
*** Bug 330478 has been marked as a duplicate of this bug. ***
Comment 6 User image :Gijs 2006-08-01 07:19:49 PDT
Note also bug 332454.
Comment 7 User image Philip Taylor 2006-08-01 10:09:28 PDT
This seems fixed for me in 1.8.1 (Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1). The test cases in bug 330478 and bug 332454 also work.

Probably related to "the handling of 1-bit images is horked (bits are packed backwards).  I'll fix." comment in bug 329598.
Comment 8 User image Chris Thomas (CTho) [formerly cst@andrew.cmu.edu cst@yecc.com] 2006-09-08 15:36:26 PDT
*** Bug 332454 has been marked as a duplicate of this bug. ***
Comment 9 User image Vladimir Vukicevic [:vlad] [:vladv] (not actively reading bugmail)) 2007-10-29 13:54:40 PDT
Fixed in trunk

Note You need to log in before you can comment on or make changes to this bug.