Last Comment Bug 329417 - preventing that other files than .wav could be selected in "new mail sound"
: preventing that other files than .wav could be selected in "new mail sound"
Status: RESOLVED DUPLICATE of bug 320189
:
Product: Thunderbird
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-05 06:24 PST by Andreas Morawietz
Modified: 2006-09-30 11:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Andreas Morawietz 2006-03-05 06:24:41 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060304 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060304 Firefox/1.5

go to Options -> General
click on Advanced under "When new messages arrive"

If you click on Browse in that window, you can select any file you want!
I selected a .png file and thunderbird doesn't show any error-message.
I closed options, still no error-message. 

You should prevent that users could select any other files than .wav

BTW: You should add .mp3 as supported sound-format!




Reproducible: Always
Comment 1 User image Andreas Morawietz 2006-03-05 06:25:05 PST
using:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060304 Thunderbird/2.0a1 ID:2006030406
Comment 2 User image zug_treno 2006-03-05 15:43:43 PST
(In reply to comment #0)
> You should prevent that users could select any other files than .wav

Related to Suite bug 266192 (todo filter by .wav)?

> BTW: You should add .mp3 as supported sound-format!

It seems that Macs already support .mp3 files, see Suite bug 172541 comment 5.
Comment 3 User image Adam Guthrie 2006-09-30 11:29:54 PDT
This was fixed by bug 320189, where WAV filtering was added. (Windows and Linux can only play WAVs.)

*** This bug has been marked as a duplicate of 320189 ***

Note You need to log in before you can comment on or make changes to this bug.