Last Comment Bug 331771 - Camino (1.8 branch) builds are broken
: Camino (1.8 branch) builds are broken
Status: VERIFIED FIXED
: fixed1.8.1
Product: Camino Graveyard
Classification: Graveyard
Component: General (show other bugs)
: 1.8 Branch
: PowerPC Mac OS X
-- normal (vote)
: ---
Assigned To: Mike Pinkerton (not reading bugmail)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-03-26 08:53 PST by Mark Mentovai
Modified: 2006-03-27 21:09 PST (History)
3 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Mark Mentovai 2006-03-26 08:53:02 PST
 
Comment 1 User image Mark Mentovai 2006-03-26 08:56:37 PST
The breakage was caused by this patch, which does not appear to have an associated bug number:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=Makefile.in&branch=1.33.18.1&root=/cvsroot&subdir=mozilla/xpfe&command=DIFF_FRAMESET&rev1=1.33&rev2=1.33.18.1

Doug, what were you trying to do with that logic flip?  Camino needs to build in the suite dirs.  We're getting an incomplete embed.jar, and the 1.8 branch universal build has gone red because it depends on buildconfig.html in embed.jar, which is now not present.  The bustage:

http://tinderbox.mozilla.org/showlog.cgi?log=MozillaTest/1143142020.7932.gz&fulltext=1
Comment 2 User image Mark Mentovai 2006-03-26 09:06:04 PST
I've checked in the following bustage fix for Camino at xpfe/Makefile.in:

-ifneq (,$(MOZ_THUNDERBIRD)$(MOZ_SUITE))
+ifneq (,$(MOZ_THUNDERBIRD)$(MOZ_SUITE)$(filter macbrowser,$(MOZ_BUILD_APP)))

but I wonder why this needs to be done differently from the trunk, which still uses this logic:

ifneq (,$(MOZ_PHOENIX)$(MOZ_XULRUNNER))
else

(possibly with $(MINIMO) added if it too only wants browser/public and browser/src?)
Comment 3 User image Doug Turner (:dougt) 2006-03-27 09:31:32 PST
Sorry for the bustage.

So this change didn't make it to the branch because we will probably not ifdef MINIMO but instead use a "embedding profile" define.  see bug 331431.

Is it safe to close this bug as fixed?
Comment 4 User image Mark Mentovai 2006-03-27 10:00:58 PST
OK.  I look forward to seeing some of that stuff stripped out of embed.jar.

Note You need to log in before you can comment on or make changes to this bug.