Last Comment Bug 333139 - Moving messages from local folder to IMAP folder causes message status to be reset
: Moving messages from local folder to IMAP folder causes message status to be ...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 All
-- major with 3 votes (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
Depends on: 371789
Blocks:
  Show dependency treegraph
 
Reported: 2006-04-07 08:46 PDT by rns.mozillabugzilla.n.semba
Modified: 2007-02-28 11:04 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image rns.mozillabugzilla.n.semba 2006-04-07 08:46:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla Thunderbird version 1.5 (20051201)

I am using the standard latest version (Thunderbird 1.5 - 20051201) on Windows XP SP2.  When I move or copy a message which has the status 'replied' or 'forwarded' from a local folder to an IMAP server, the new message on the server no longer has the 'replied' or 'forwarded' status, and instead has the same appearance as a read message which has not had a reply or forward action carried out on it. 

The server I have tested against was a Courier IMAP server v3.0.8

Reproducible: Always

Steps to Reproduce:
1. Set up an IMAP account, as well as Local Folders
2. Locate a message in the Local Folders, which has as its status either "replied" or "forwarded"
3. Copy or move this message to a folder in the IMAP account (by drag-and-drop or via the context-menus)

Actual Results:  
The copied/moved message no longer has the "replied" or "forwarded" status associated with it, and instead appears as a generic, read mail.

Expected Results:  
The copied/moved message should also have copied the message status information, and the message in the IMAP folder should have a corresponding "replied" or "forwarded" status.

This only happens when moving messages from Local Folders to IMAP folders.  Moving a similar message from an IMAP folder to a Local Folder results in the status being copied as well. 

I am not using any extensions in Thunderbird.
Comment 1 User image Magnus Melin [:mkmelin] 2006-04-07 10:32:23 PDT
Confirmed on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060407 Thunderbird/2.0a1 ID:2006040704
Comment 2 User image Jürgen Nagler-Ihlein 2006-12-05 03:07:47 PST
I switched IMAP logging on and followed the actions taken by TB copying or moving a message from local folders or even a second IMAP account to an (other) IMAP account. Not only the status for 'forwarded' (TB uses the IMAP flag '$Forwarded' for this) or 'replied' (TB IMAP flag: '\Answered') is lost but also the flag (Message/Mark/Flag) (TB IMAP flag: '\Flagged') and the Junk status (TB IMAP flags: 'NonJunk' and 'Junk'). The only status flag copied are the (TB IMAP flag: '\Seen') and labels/tags (TB IMAP flags: '$Label1' to 'Label5').

Logging shows the flags for a messages on IMAP server A:
1632[2837278]: 2856d20:imap-server-A.de:S-INBOX:CreateNewLineFromSocket: * 701 FETCH (FLAGS (\Answered \Flagged \Seen $Forwarded $Label3) UID 81303)

But copying it to IMAP server B sets:
1272[27f4fd0]: 282b020:imap-server-B.de:S-INBOX:ProcessCurrentURL:imap://username@imap-server-B.de:993/appendmsgfromfile%3E/INBOX:  = currentUrl
1272[27f4fd0]: 282b020:imap-server-B.de:S-INBOX:SendData: 14 append "INBOX" (\Seen $Label3) {53695+}

Only IMAP flags (\Seen $Label3) out of (\Answered \Flagged \Seen $Forwarded $Label3) are set on the destination IMAP server.

Reproducible by logging (NSPR_LOG_MODULES=IMAP:5) for Thunderbird 1.5.0.8 (20061025), SeaMonkey 1.0.6 and SeaMonkey 1.1 Beta on Windows.
Comment 3 User image David :Bienvenu 2006-12-05 07:09:20 PST
this should be fixed in our 2.0 beta that's coming out soon - the fix is also available in pre-beta builds. That fix was checked in as part of bug 360463, so I'm going to mark this as a dup.

*** This bug has been marked as a duplicate of 360463 ***
Comment 4 User image Magnus Melin [:mkmelin] 2006-12-05 10:01:48 PST
This isn't resolved. Replied/forwarded status is only kept for POP -> POP. 
IMAP -> IMAP, IMAP -> POP and POP -> IMAP still seems broken.

Reopening this (though it may in fact be a duplicate...), to avoid clutter in the other bug.
Comment 5 User image Mike Cowperthwaite 2007-01-17 17:03:16 PST
(In reply to comment #4)
> This isn't resolved. Replied/forwarded status is only kept for POP -> POP. 
> IMAP -> IMAP, IMAP -> POP and POP -> IMAP still seems broken.

Magnus, per your bug 290099 comment 6, is this a dupe of that one?  Or is 290099 the one you mean by "the other bug"?  That is, are you making a distinction between the IMAP->Local case (that bug) and the Local->IMAP one (this bug)?
Comment 6 User image Magnus Melin [:mkmelin] 2007-01-18 09:49:02 PST
No that was only about junk status (which seems fine now). 

I retested this too, seems replied status is ok for POP -> POP and IMAP -> POP.

IMAP -> IMAP and POP -> IMAP still seems broken. 
(using todays 2.0 nightly)
Comment 7 User image Magnus Melin [:mkmelin] 2007-02-28 11:04:48 PST
This was fixed by yesterdays checkin for bug 371789. Thx David! 
Marking FIXED.


Note You need to log in before you can comment on or make changes to this bug.