Last Comment Bug 349920 - freebl libraries are always optimized on Sparc
: freebl libraries are always optimized on Sparc
Status: RESOLVED FIXED
:
Product: NSS
Classification: Components
Component: Libraries (show other bugs)
: 3.11.2
: Sun SunOS
P2 normal (vote)
: 3.11.3
Assigned To: Julien Pierre
:
: J.C. Jones [:jcj] (he/him)
Mentors:
: 349928 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-23 13:09 PDT by Julien Pierre
Modified: 2006-08-23 15:58 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Only use optimizer flags if BUILD_OPT is set . Also delete -fns which has no effect (3.17 KB, patch)
2006-08-23 14:52 PDT, Julien Pierre
neil.williams: review+
nelson: review+
Details | Diff | Splinter Review

Description User image Julien Pierre 2006-08-23 13:09:57 PDT
Currently, the freebl libraries are always optimized on Ultrasparc, even in our debug builds. This is because the optimizer flags were added to the SOL_CFLAGS gmake variable, which is used for both debug and optimized builds.
Comment 1 User image Julien Pierre 2006-08-23 14:51:34 PDT
*** Bug 349928 has been marked as a duplicate of this bug. ***
Comment 2 User image Julien Pierre 2006-08-23 14:52:25 PDT
Created attachment 235153 [details] [diff] [review]
Only use optimizer flags if BUILD_OPT is set . Also delete -fns which has no effect
Comment 3 User image Neil Williams 2006-08-23 15:41:31 PDT
Comment on attachment 235153 [details] [diff] [review]
Only use optimizer flags if BUILD_OPT is set . Also delete -fns which has no effect

Looks good. I wonder what -xdepend (no argument) defaults to.
Comment 4 User image Nelson Bolyard (seldom reads bugmail) 2006-08-23 15:48:51 PDT
Comment on attachment 235153 [details] [diff] [review]
Only use optimizer flags if BUILD_OPT is set . Also delete -fns which has no effect

r=nelson
Comment 5 User image Julien Pierre 2006-08-23 15:58:03 PDT
Thanks for the quick reviews to both of you.

-xdepend is set to no by default . It is dangerous, because setting it automatically raises optimization level to -xO3, so it definitely needs to be left off in the debug build .

I checked in this patch to the tip :

Checking in Makefile;
/cvsroot/mozilla/security/nss/lib/freebl/Makefile,v  <--  Makefile
new revision: 1.86; previous revision: 1.85
done

And to NSS_3_11_BRANCH :

Checking in Makefile;
/cvsroot/mozilla/security/nss/lib/freebl/Makefile,v  <--  Makefile
new revision: 1.70.2.11; previous revision: 1.70.2.10
done

Note You need to log in before you can comment on or make changes to this bug.