Last Comment Bug 378064 - Sending Message dialog box does not close after message copies to Sent folder
: Sending Message dialog box does not close after message copies to Sent folder
Status: RESOLVED WORKSFORME
: regression
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: All All
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-04-19 11:41 PDT by Diane Hartman
Modified: 2008-07-31 04:30 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screen shot (8.66 KB, image/jpeg)
2008-01-31 11:21 PST, Abhi
no flags Details

Description User image Diane Hartman 2007-04-19 11:41:04 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

After sending a message, the "Sending Message" dialog box shows the progress of send.  When copying message to sent file the dialog box sometimes fails to close when copy is complete.  The progress bar indicates the copy is complete but the dialog box never closes.  It must be closed manually.  I cannot duplicate the problem - it happens randomly but appears to happen more often when I have written a long message.

Reproducible: Sometimes

Steps to Reproduce:
1. Can't reproduce - happens randomly
2.
3.
Actual Results:  
Dialog box that tracks the sending of a message and the copying to the Sent folder fails to close

Expected Results:  
Expected it to close
Comment 1 User image Willie Reid 2008-01-26 11:28:14 PST
This is happening again.
Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.9b3pre) Gecko/2008012601 SeaMonkey/2.0a1pre ID:2008012601

For what it's worth. I am also recently experiencing this behaviour in Thunderbird
(Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3pre) Gecko/2008012603 Thunderbird/3.0a1pre ID:2008012603)
Comment 2 User image Abhi 2008-01-31 11:20:01 PST
I can reproduce this error 100% on Thunderbird 3.0 Alpha
Mail Account is IMAP type (not sure if this makes any difference)
Steps:
1. Compose a new mail
   specify mail address, type some subject and put some body
2. Send message

Changes: In 3.0 alpha, the message box disappears after 1-1.5 minutes.

Attaching screen shot image (taken 45 seconds after the progress bar showed 100%)
Comment 3 User image Abhi 2008-01-31 11:21:41 PST
Created attachment 300691 [details]
Screen shot

screen shot
Comment 4 User image Joshua Cranmer [:jcranmer] 2008-02-20 14:56:01 PST
Confirmed independently by developers on Vista, Linux, and Mac for both trunk Thunderbird and Seamonkey builds -> definitely not tied to a specific OS/Platform.
Comment 5 User image Wayne Mery (:wsmwk) 2008-02-20 14:58:03 PST
in vista thunderbird version 3.0a1pre (2008022003) - it is sufficient to hover over the dialog and it goes away in ~5sec
Comment 6 User image Wayne Mery (:wsmwk) 2008-02-20 15:38:29 PST
works version 3.0a1pre (2008011503)
fails version 3.0a1pre (2008011603)
wonder who?

amending comment 5, goes away in ~5sec if one _moves_ mouse around in dialog.
(reminds me of another bug from some time ago which I can't remember)
Comment 7 User image Wayne Mery (:wsmwk) 2008-02-27 12:39:42 PST
bug 413200 documents the trunk regression issue.

bug reporter's email address is dead and no other reports of this problem so this bug should probably be closed incomplete - perhaps was a server issue - unless someone wants to morph this bug.
Comment 8 User image Wayne Mery (:wsmwk) 2008-05-13 04:31:05 PDT
problem gone?
(seems to be for me)
Comment 9 User image Willie Reid 2008-05-13 06:55:16 PDT
Cured for me also.
Comment 10 User image Wayne Mery (:wsmwk) 2008-05-13 07:01:28 PDT
=> WFM then.  Let's hope it's also working for Diane on seamonkey

Note You need to log in before you can comment on or make changes to this bug.