Last Comment Bug 379453 - Java plugin not disabling correctly.
: Java plugin not disabling correctly.
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: unspecified
: PowerPC macOS
-- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jared Wein [:jaws] (Regression Engineering Owner for 65) (please needinfo? me)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-02 05:23 PDT by Ade
Modified: 2007-05-02 07:29 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Ade 2007-05-02 05:23:39 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

When Java is disabled in the Content tab, under Preferences, the browser information still shows that Java is enabled. Checking "about:plugins" in the URL shows all plugin information and shows that Java is still enabled.

However, if you try and run a Java applet, it does not work because Java is disabled.

Reproducible: Always

Steps to Reproduce:
1.Open Firefox and go to Preferences.
2.Click on Content tab and deselect the "Enable Java" check box.
3.Type "about:plugins" in the Firefox URL.
4.Java plugins still show as enabled.  
Actual Results:  
Java plugins still show as enabled. Java plugins show "Yes" under the enabled column. 

Expected Results:  
The Java plugins shoud show say "No" under the enabled column.

The software should report that the Java plugins have been disabled.
Comment 1 User image Steven Michaud [:smichaud] (Retired) 2007-05-02 07:29:58 PDT
The information displayed in about:plugins for the Java Embedding
Plugin is static -- it's compiled into a binary, and can't be changed
according to how the browser's settings change.  The same thing is
true for the Sun Java Plugin on Linux and Windows.

Since there's no way to "fix" this problem, I'm marking it WONTFIX.

But it's still possible to use the Java Embedding Plugin's
about:plugins display to determine whether or not Java is enabled:
Click on the "Java Information" link (after "Run version test) -- if
you've disabled Java, it will tell you that "Java is NOT enabled".

Note You need to log in before you can comment on or make changes to this bug.