Last Comment Bug 469780 - everytime I try to download a file, browser closes and reports a bug
: everytime I try to download a file, browser closes and reports a bug
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: File Handling (show other bugs)
: unspecified
: x86 Windows Vista
-- critical (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :Paolo Amadini
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-15 19:39 PST by KWGPC
Modified: 2008-12-17 18:57 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image KWGPC 2008-12-15 19:39:27 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

this is a report given in vista after browser closing

Problem signature:
  Problem Event Name:	BEX
  Application Name:	firefox.exe
  Application Version:	1.9.0.3224
  Application Timestamp:	49094c66
  Fault Module Name:	CybDefCom.dll_unloaded
  Fault Module Version:	0.0.0.0
  Fault Module Timestamp:	46153456
  Exception Offset:	100232ae
  Exception Code:	c0000005
  Exception Data:	00000008
  OS Version:	6.0.6000.2.0.0.256.1
  Locale ID:	1033
  Additional Information 1:	2b5e
  Additional Information 2:	d41d8cd98f00b204e9800998ecf8427e
  Additional Information 3:	3c2b
  Additional Information 4:	92ae8ec7273ee2de47d5964e99a2ad9b

Read our privacy statement:
  http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409


Reproducible: Always

Steps to Reproduce:
1.
2.
3.


Expected Results:  
should of downloaded file without the browser wanting to close all the time
Comment 1 User image Matthias Versen [:Matti] 2008-12-15 20:11:08 PST
This is caused by a bug in CybDefCom.dll which should belong to cyberdefender2.0.

Please provide a crash ID, read https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

Firefox calls the local Antivirus software for scanning the file after downloading it but it seems that your AV software (cyberdefender 2.0) crashes.
Ycan disable the AV scanning in Firefox in about:config if you change browser.download.manager.scanWhenDone to false.
Comment 2 User image rahilkamra 2008-12-16 01:44:53 PST
Hi
I work for Cyberdefender Technical Support, we are working on it and will get back to you.
Comment 3 User image Matthias Versen [:Matti] 2008-12-16 01:58:48 PST
Additional Information:
Firefox calls the Windows API for the virus scanning. ( IOfficeAntiVirus , http://msdn.microsoft.com/en-us/library/ms537369.aspx )
We have also a Norton crasher in bugzilla (bug 458667) that only seem to happen if you install windows defender after Norton.

Ask if you have additional questions.
Comment 4 User image rahilkamra 2008-12-17 18:29:24 PST
Cyberdefender Technical Team checked it out and found that Antivirus 2009, which claims to be an antivirus program is responsible for the browser to crash and report a bug.
Comment 5 User image Matthias Versen [:Matti] 2008-12-17 18:57:53 PST
Thanks for the quick response from the Cyberdefender Support !
marking invalid as this is not a firefox bug

Note You need to log in before you can comment on or make changes to this bug.