Last Comment Bug 484511 - The cursor doesn't update if a drop target changes the dropEffect or effectAllowed values
: The cursor doesn't update if a drop target changes the dropEffect or effectAl...
Status: RESOLVED DUPLICATE of bug 1121946
:
Product: Core
Classification: Components
Component: Drag and Drop (show other bugs)
: unspecified
: x86 Windows Vista
-- normal with 4 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Neil Deakin (not available until Aug 9)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-20 19:45 PDT by Sebastian Markbåge
Modified: 2015-10-22 05:40 PDT (History)
3 users (show)
benjamin: blocking1.9.2-
sebastian: wanted1.9.1?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image Sebastian Markbåge 2009-03-20 19:45:38 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

When the user moves the cursor over a drop target that overrides the dropEffect or effectAllowed values during the dragenter or dragover events, the cursor isn't updated to the corresponding values.

Reproducible: Always

Steps to Reproduce:
Start a drag operation and during the dragstart event, set event.dataTransfer.effectAllowed = 'all';

During the dragenter and dragover events of a target element, set event.dataTransfer.dropEffect = 'copy';
or
event.dataTransfer.effectAllowed = 'copy';
Actual Results:  
The cursor now shows the "move"-cursor unless you use a modifier key.

Expected Results:  
The cursor should instead show the "copy" since the dropEffect or effectAllowed has been changed and the operation will be allowed to perform a drop.

Whether or not the user should be able to change the dropEffect using modifier keys after it has been explicitly overridden is not the point here. It's the fact that the cursor doesn't correspond to the current operation that will be performed.
Comment 1 User image Julien Bachmann 2009-11-26 00:47:25 PST
I have noticed the same problem on Firefox 3.5.5 on Mac OSX.
Comment 2 User image Neil Deakin (not available until Aug 9) 2015-10-22 05:40:50 PDT

*** This bug has been marked as a duplicate of bug 1121946 ***

Note You need to log in before you can comment on or make changes to this bug.