Last Comment Bug 494849 - Freezing after wake from sleep [Mac]
: Freezing after wake from sleep [Mac]
Status: RESOLVED WORKSFORME
: hang, qawanted
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
-- critical (vote)
: ---
Assigned To: David :Bienvenu
:
:
Mentors:
: 491987 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 00:06 PDT by Gary Kwong [:gkw] [:nth10sd]
Modified: 2010-04-07 22:08 PDT (History)
8 users (show)
dmose: wanted‑thunderbird+
standard8: blocking‑thunderbird3-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
stack from running `thread apply all bt` in gdb (23.15 KB, text/plain)
2009-05-26 00:06 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details
Activity manager sample (14.38 KB, text/plain)
2009-05-26 00:12 PDT, Gary Kwong [:gkw] [:nth10sd]
no flags Details

Description User image Gary Kwong [:gkw] [:nth10sd] 2009-05-26 00:06:31 PDT
Created attachment 379647 [details]
stack from running `thread apply all bt` in gdb

I get this really occasionally - have a hang stack. Basically my MBP went to sleep and when I wake it (after quite a number of hours), debug Thunderbird is freezing.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090523 Lightning/1.0pre Shredder/3.0b3pre

This doesn't happen often. I re-tried again and it doesn't hang after that. Hopefully the stack is useful.
Comment 1 User image Gary Kwong [:gkw] [:nth10sd] 2009-05-26 00:12:09 PDT
Created attachment 379648 [details]
Activity manager sample

Attaching this in case either stack might be useful.
Comment 2 User image Gary Kwong [:gkw] [:nth10sd] 2009-05-26 00:13:57 PDT
(In reply to comment #0)
> Created an attachment (id=379647) [details]
> stack from running `thread apply all bt` in gdb

This is the part that seems suspicious:

Thread 6 (process 950 thread 0x6903):
#0  0x00000000 in ?? ()
Cannot access memory at address 0x4

bienvenu, any idea what's going on, is this worth nominating for blocking?
Comment 3 User image Gary Kwong [:gkw] [:nth10sd] 2009-05-26 00:46:18 PDT
Sidenote on how to get a hang stack using gdb:

If running debug thunderbird, either clicking Sample Process in activity manager will get a sample, or follow the following (slightly modified, original credit Steven Michaud) instructions from bug 470001 comment 23 :

1) Run Shredder.

2) Do 'ps ax | grep thunderbird' at a Terminal prompt to find its
   process id.

   The pid will be listed in the first column to the left.  Let's
   assume it's '123'.

3) Do 'gdb thunderbird 123' to attach to the Shredder process.

Additional step:

4) Do 'thread apply all bt' to get a backtrace of all running TB threads, then attach the output to a bug report here in b.m.o
Comment 4 User image Gary Kwong [:gkw] [:nth10sd] 2009-05-26 03:43:29 PDT
(In reply to comment #3)
> Sidenote on how to get a hang stack using gdb:

(Has been transferred to a wiki page at https://wiki.mozilla.org/Thunderbird:Testing:Get_A_Debug_Thunderbird_Hang_Stack )
Comment 5 User image David :Bienvenu 2009-05-26 08:27:42 PDT
I think thread 1 and thread 13 are blocking each other - I don't know about the thread that crashed with a 0+4 deref - there's not enough info in the stack there.
Comment 6 User image Mark Banner (:standard8) 2009-05-26 13:01:01 PDT
Interestingly, I put my laptop to sleep etc quite a few times over last weekend (Thur-Sunday) and didn't see this at all.
Comment 7 User image Ludovic Hirlimann [:Usul] 2009-05-27 02:24:18 PDT
The way I get this is by closing the screen - that's the way I put my laptop to sleep. Sometimes when I wake it up - the next morning or a bit later Tb is hanged.
The profile as 2 gmail accounts, 2 newsgroup accounts, and one RSS/blog.
Comment 8 User image Ludovic Hirlimann [:Usul] 2009-05-28 11:10:54 PDT
*** Bug 491987 has been marked as a duplicate of this bug. ***
Comment 9 User image David :Bienvenu 2009-06-09 07:58:56 PDT
putting in b4
Comment 10 User image Mark Banner (:standard8) 2009-08-18 14:24:43 PDT
The Thunderbird drivers wish to release Thunderbird 3 as soon as possible. As a result, we feel that this bug shouldn't stand in the way of all the other good work getting into the hands of users sooner rather than later. Therefore we are retargeting it for 3.1. See http://ccgi.standard8.plus.com/blog/archives/242 for more details. The 3.1 release is expected to be a quick release soon after Thunderbird 3.
Comment 11 User image Wayne Mery (:wsmwk) 2010-01-06 08:38:49 PST
is this still seen with trunk builds?

related?  Bug 536155 -  Thunderbird hangs on Get Mail from a Mac.com/Me.com IMAP account when waking from sleep.
Comment 12 User image Dan Mosedale (:dmose, :dmosedale) 2010-02-10 17:23:27 PST
Since this doesn't appear to be a regression from Thunderbird 2, and it seems to be effecting a very small number of users, I don't think this wants to block Tb 3.1, so minusing.  bienvenu, feel free to change if you disagree...
Comment 13 User image David :Bienvenu 2010-02-11 09:12:23 PST
This falls into the category of bugs that I would probably block on if I could reproduce them. It's not at all clear that it's not a regression from TB 2, though TB 2 probably had a separate set of issues.
Comment 14 User image Dan Mosedale (:dmose, :dmosedale) 2010-02-11 09:36:14 PST
Adding qawanted in the hopes of finding steps to reproduce.  If those appear, this should be nominated to block whatever release is current.
Comment 15 User image Gary Kwong [:gkw] [:nth10sd] 2010-04-07 22:08:12 PDT
I think this has largely WFM since. Been running 3.0.4 without issue for some weeks and only just shifted to Lanikai.

Note You need to log in before you can comment on or make changes to this bug.