Last Comment Bug 552080 - overflow on tbody doesn't work in Firefox 3.7 alpha
: overflow on tbody doesn't work in Firefox 3.7 alpha
Status: RESOLVED DUPLICATE of bug 577308
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
-- major with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Justin Dolske [:Dolske]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-12 14:45 PST by Jørn Holm
Modified: 2010-07-21 09:45 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Test case for overflow on tbody (also my testcase for text-overflow: ellipsis) (13.35 KB, text/html)
2010-03-12 14:48 PST, Jørn Holm
no flags Details

Description User image Jørn Holm 2010-03-12 14:45:12 PST
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a3pre) Gecko/20100312 Minefield/3.7a3pre

Scrolling on tbody when tbody has a height and overflow set to auto doesn't work in Firefox 3.7 alpha.


Reproducible: Always

Steps to Reproduce:
Create a table with 
<tbody style="height: 100px; overflow: auto">
Comment 1 User image Jørn Holm 2010-03-12 14:48:01 PST
Created attachment 432240 [details]
Test case for overflow on tbody (also my testcase for text-overflow: ellipsis)
Comment 2 User image philippe (part-time) 2010-03-12 16:59:32 PST
Bug 28800 remove support for scrolling on rowgroups.
Comment 3 User image Jørn Holm 2010-03-13 10:55:33 PST
Has scrolling on rowgroups been removed!!!

Who in there right mind would do that? 
When creating web applications for different companies we always recommend developing for Firefox because Firefox is the only one supporting this great feature. "Every body" want's information displayed in tables with static header (and sometimes footer).

We can of courses do something similar with javascript, but I can't see any good reason for why this shouldn't be as simple as style="height: 100px; overflow: auto" (Even if it isn't 100% up the the standards).

I it will get removed you should also post a it as an up coming "feature" at:
https://developer.mozilla.org/en/Upcoming_Firefox_features_for_developers

I personally knows a lot of Intranet applications which will break, and developers needs a head up to warn their customers.
Comment 4 User image Andreas Joseph Krogh 2010-03-16 03:06:35 PDT
I second Jørn's concern here. This would be tragic and represent a giant step *backwords* in modern web-technology. Someone should really put up a large warning-sign somewhere.

Is there a *single* argument for removing this functionality?
Comment 5 User image j.j. 2010-07-21 07:28:54 PDT
> Is there a *single* argument for removing this functionality?

Incompatible with CSS standard and other browsers, see bug 28800 comment 37

*** This bug has been marked as a duplicate of bug 577308 ***
Comment 6 User image Andreas Joseph Krogh 2010-07-21 09:45:32 PDT
Well, plenty of stuff has become a standard *because* it once was implemented by someone needing the functionality despite it, at the time, was incompatible with whatever standard.
If you ask users instead of some committee I'm sure everyone developing serious web-applications really need scrolling tbody, regardless of whether it's part of a standard or not.

Thumbs down to the Mozilla team this time!

Note You need to log in before you can comment on or make changes to this bug.