Last Comment Bug 563207 - Taking a screenshot of Firefox displays an old title from a page viewed long ago during a private browsing session
: Taking a screenshot of Firefox displays an old title from a page viewed long ...
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: unspecified
: x86 Windows Vista
-- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Josh Matthews [:jdm]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-01 21:19 PDT by oaqbsvgpxk
Modified: 2010-07-09 14:11 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description User image oaqbsvgpxk 2010-05-01 21:19:12 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

I just took a screenshot (using GIMP) of some page that I was viewing.  When I looked at the screenshot, everything was normal, except that the window's title bar didn't display the title of the page I was looking at.  Instead, it displayed part of that, but it was mostly overwritten with the title of a page that I viewed quite some time ago.  

To make matters worse, that page that I viewed quite some time ago, I viewed in private browsing mode.  And, to be clear, I had long since exited private browsing mode.

Reproducible: Always

Steps to Reproduce:
1. Enter private browsing mode.
2. Go to a page with some horribly embarrassing title.
3. Do what you will.
4. Exit private browsing mode.
5. Go to some nice friendly page with pictures of fluffy bunnies on it.
6. Start up GIMP.
7. "File / Create / Screen Shot / Grab a single window".
8. Drag the crosshairs to the Firefox window.
9. Save the resulting screenshot.
10. Don't notice that the title bar in the screenshot says something very, very different than "Fluffy Bunny Page".
11. Send the screenshot in an email to Grandma.
Actual Results:  
Grandma now knows that you're a disgusting pervert.

Expected Results:  
Grandma loves the fluffy bunny picture that you sent her.
Comment 1 User image :Ehsan Akhgari 2010-05-03 16:12:44 PDT
Does the correct title appear on the screen? Can you reproduce this every time?  Do you see any errors reported to the Error Console?
Comment 2 User image Matthias Versen [:Matti] 2010-07-09 14:11:35 PDT
no response

Note You need to log in before you can comment on or make changes to this bug.