Last Comment Bug 717895 - IMAP: emails archived from Trash seem to disappear
: IMAP: emails archived from Trash seem to disappear
Status: RESOLVED INCOMPLETE
:
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: 3.1
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-13 05:32 PST by Shi Sherebrin
Modified: 2014-12-15 15:47 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Shi Sherebrin 2012-01-13 05:32:37 PST
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I had an email from 2010 selected in the Trash folder of my IMAP account.  I pressed 'A' to archive it.


Actual results:

When I looked in the 2010 folder under Archives, I could not find the 'archived' email (it also was not in the 2012 folder).  I also looked on the IMAP server (dovecot implementation) and could not find a corresponding file.  I was able to reproduce this problem with another email.  At first I was able to Undo the archive operation, but then after a few minutes I was no longer able to do so.


Expected results:

The email should have been moved to the 2010 folder under Archives.
Comment 1 User image Hashem Masoud 2012-01-14 00:00:52 PST
(In reply to Shi Sherebrin from comment #0)
See if this can help: http://kb.mozillazine.org/Disappearing_mail
Comment 2 User image Shi Sherebrin 2012-01-14 11:21:10 PST
Thanks for the link, which I just read.  I do not think the issues listed there are involved here.

I did another experiment, and have a more detailed procedure which seems to cause disappearance of the message (using IMAP):

1. Select a message in the Trash
2. Press A to archive it
3. Undo the archiving operation with Ctrl+Z

After step 2, the message did appear in the the archive folder, but after step 3 I found that the message did not appear back in the Trash.
Comment 3 User image WADA:World Anti-bad-Duping Agency 2012-01-14 20:25:11 PST
Same phenomenon as bug 618809?
> Unread deleted mail can not be restored from the trash folder
> with mail.server.default.dup.action = 2 (move duplicated mails to trash)

bug 618809
 Delete at Inbox == Move from Inbox to Trash
                 == Copy from Inbox to Trash + Store flag \Deleted at Inbox
 Undo Delete     == Move back from Trash to Inbox
                 == Copy from Trash to Inbox + Store flag \Deleted at Trash
comment #0   
 Delete at Archives == Move from Archives to Trash
                    == Copy to Trash + Store flag \Deleted at Archives
 Archive at Trash   == Move from Trash to Archives
                    == Copy from Trash to Archives + Store flag \Deleted at Trash
comment #2   
 Delete at Inbox  == Move from Inbox to Trash 
                  == Copy from Inbox to Trash + Store flag \Deleted at Inbox
 Archive at Trash == Move from Trash to Archives
                  == Copy from Trash to Archives + Store flag \Deleted at Trash
 Undo Archive  == Move back from Archives to Trash
               == Copy from Archives to Trash + Store flag \Deleted at Archives

In any case, duplicate mail happens at a mail folder by Undo Delete or Archive or Undo Archive, and it's affected by mail.server.default.dup.action = 2.
Comment 4 User image Shi Sherebrin 2012-01-15 00:46:03 PST
Thanks, but the other bug doesn't seem related: I checked mail.server.default.dup_action in my config editor and it is set to 0.
Comment 5 User image WADA:World Anti-bad-Duping Agency 2012-01-15 21:49:16 PST
What is offline-use setting of Inbox and Trash? (Folder Properties, Synchronization)
What is UID of relevant mails? (show "Order Received" column. value is UID of mail if IMAP)
Can you get IMAP log file? ( see bug 402793 comment #28 )
What command does Tb issue when Delete/Archive/Undo etc. is requested? What response does server return to command?

If you attach log file to this bug, remove/replace personal information from log file, please. And remove mail data please, because mail data itself is irrelevant to problem and required data is folder status(Inbox, Trash, Archives etc. in your case), uid of mails, command requested by Tb, and notification/response from server for relevant mails. Please never paste data to bug at B.M.O if data is long.
Comment 6 User image Wayne Mery (:wsmwk) 2014-11-25 19:53:05 PST
(In reply to WADA from comment #5)
> What is offline-use setting of Inbox and Trash? (Folder Properties,
> Synchronization)
> What is UID of relevant mails? (show "Order Received" column. value is UID
> of mail if IMAP)
> Can you get IMAP log file? ( see bug 402793 comment #28 )
> What command does Tb issue when Delete/Archive/Undo etc. is requested? What
> response does server return to command?

Shi?
Comment 7 User image Shi Sherebrin 2014-11-26 01:27:02 PST
Thanks for the reminder, Wayne.  WADA's query must have gotten buried in my inbox, and forgotten.

I'll try to follow this up soon.
Comment 8 User image Phoenix 2014-12-15 15:47:43 PST
Resolved per whiteboard
Feel free to reopen when you'll have new data

Note You need to log in before you can comment on or make changes to this bug.