Last Comment Bug 737586 - SVG radial gradients with repeat or reflect not rendered
: SVG radial gradients with repeat or reflect not rendered
Status: NEW
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Windows 7
-- normal with 2 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jessie
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 12:43 PDT by rees-sx@hotmail.co.uk
Modified: 2012-03-20 14:30 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screengrab W3 SVG gradient test (60.07 KB, image/png)
2012-03-20 12:43 PDT, rees-sx@hotmail.co.uk
no flags Details

Description User image rees-sx@hotmail.co.uk 2012-03-20 12:43:11 PDT
Created attachment 607666 [details]
Screengrab W3 SVG gradient test

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

Opened:
http://www.w3.org/Graphics/SVG/Test/20110816/harness/htmlObjectApproved/pservers-grad-14-b.html

1) Everyday setup:
2) Switched to safe mode:
3) Disabled all pulgins and addons:
4) Created new Firefox profile in new user account & disabled all plugins:


Actual results:

1) spreadMethod="reflect" and spreadMethod="repeat" failed to render.

    spreadMethod="pad" and spreadMethod="default" rendered as expected. 

2) All rendered as expected - test passed.
3) As results 1)
4) As results 1)


Expected results:

All the results should match the W3 png image.

Further to:
Bug 296411
https://bugzilla.mozilla.org/show_bug.cgi?id=296411

Robert Longson said the test passed for him, so I thought to try safe mode and all tests pass. 
But disabling plugins and addons, then running in normal mode the test again fails. 
As did a fresh profile and plugins disabled.

FF 11 on Win7 64 bit
Comment 1 User image Alice0775 White 2012-03-20 13:25:13 PDT
Confirmed with HWA on.
http://hg.mozilla.org/mozilla-central/rev/ee554888d071
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120320 Firefox/14.0a1 ID:20120320043530
Comment 2 User image Bas Schouten (:bas.schouten) 2012-03-20 13:41:43 PDT
Sounds like this must've regressed somewhere? Possibly with the Cairo update? Might've always been there too I suppose. Does this work with Azure Content rendering (gfx.content.azure.enabled set to true and Direct2D on).
Comment 3 User image Alice0775 White 2012-03-20 13:53:15 PDT
(In reply to Bas Schouten (:bas) from comment #2)
> Sounds like this must've regressed somewhere? Possibly with the Cairo
> update? Might've always been there too I suppose. Does this work with Azure
> Content rendering (gfx.content.azure.enabled set to true and Direct2D on).

2nd and 3rd row of 1st and 2nd column also fails in Minefield/4.0b3pre ID:20100728225315.
2nd and 3rd row of 1st column was fixed by Bug 581089.

This also fails in Firefox4.0.2 as same as Nightly14.0a1.

It works if gfx.content.azure.enabled set to true and Direct2D on.

Note You need to log in before you can comment on or make changes to this bug.