Last Comment Bug 74968 - musicplay.de - JavaScript driven menu isn't loaded.
: musicplay.de - JavaScript driven menu isn't loaded.
Status: VERIFIED INVALID
:
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: German (show other bugs)
: unspecified
: x86 Linux
P4 normal
: ---
Assigned To: Tristan Nitot
: z-aillon.c-obsolete2
:
Mentors:
http://www.musicplay.de
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-04-06 02:54 PDT by Matthias Dahl
Modified: 2015-04-19 23:45 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Matthias Dahl 2001-04-06 02:54:48 PDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.3-ac2 i686; en-US; 0.8.1)
BuildID:    2001040409

The JavaScript driven menu at http://www.musicplay.de/ doesn't load. It keeps on
displaying that it is loading but nothing happens.

Reproducible: Always
Steps to Reproduce:
1.Surf to http://www.musicplay.de/



Actual Results:  Menu at the left side isn't loaded (keeps on showing "Lade
Menü..").

Expected Results:  Menu should be loaded (works perfect with Netscape 4.7x).
Comment 1 User image Conor Lennon 2001-04-06 05:39:47 PDT
The problem here is the way the menu is written.
Html for the menu is generated and then written using the following:
(It's near the end of the showMenu function in menu.js if you're interested)

  if (document.all)
  {
    document.all['men'].innerHTML=code;
  }
  else
  {
    x=document.layers.men_layer.document;
    x.open();
    x.write(code);
    x.close();
  }

document.all will be false for mozlla, and so document.layers is used, which is
what the standards contain, (and not what mozilla uses).
The page will work if this is added before the 'else':
else if (document.getElementById)
{
    document.getElementById('men').innerHTML=code;
}
Comment 2 User image Conor Lennon 2001-04-06 05:41:35 PDT
Oops. I missed out a 'not' in my previous comment.
I should have said that document.layers is not what the standards contain.
Comment 3 User image Gilles Durys 2001-04-06 08:18:11 PDT
-> Evangelism

Thx Connor
Comment 4 User image Matthias Dahl 2001-04-18 04:50:05 PDT
Thanks for the detailed information! :) I'll try to contact the webmaster of the
site and maybe I can get them to include your fix...
Comment 5 User image Blake Ross 2001-04-29 11:44:39 PDT
Reassigning evangelism bugs to bclary@netscape.com.
Comment 6 User image Cindy Roberts 2001-06-20 22:03:48 PDT
Assigning to Euro Evangelist
Comment 7 User image z-aillon.c-obsolete2 2001-09-17 21:54:39 PDT
Moving to new component "West Europe".  European component is being removed. 
See bug 95808 for details.
Comment 8 User image Doron Rosenberg (IBM) 2001-09-26 12:35:49 PDT
site seems dead
Comment 9 User image Matthias Dahl 2001-09-28 12:24:48 PDT
Indeed the company has gone out of business - like so many in the past few month
unfortunately. :(
Comment 10 User image Doron Rosenberg (IBM) 2001-09-29 10:06:08 PDT
invalid then (fixed is kinda futile if the site is dead).
Comment 11 User image z-aillon.c-obsolete2 2001-09-29 11:15:01 PDT
See what happens when people don't use standards compliant pages?  Less people
are able to access their site and spend money on all the web goodies they
sell/provide.

I wonder if we can market that for our evangelism campaign...  heh :)

Verifying INVALID - site doesn't exist.
Comment 12 User image Kai Lahmann (is there, where MNG is) 2003-06-10 18:44:29 PDT
move...

Note You need to log in before you can comment on or make changes to this bug.