Last Comment Bug 768046 - Tab Tray Tweaks (phone)
: Tab Tray Tweaks (phone)
Status: RESOLVED INVALID
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 15 Branch
: x86 Mac OS X
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: :sdaswani only needinfo
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-25 09:40 PDT by Ian Barlow (:ibarlow)
Modified: 2013-12-10 10:01 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
tab tray tweaks (516.64 KB, image/png)
2012-06-25 09:40 PDT, Ian Barlow (:ibarlow)
no flags Details
Mockup of tablet tweaks (1.04 MB, image/png)
2012-06-26 12:41 PDT, Ian Barlow (:ibarlow)
no flags Details

Description User image Ian Barlow (:ibarlow) 2012-06-25 09:40:49 PDT
Created attachment 636349 [details]
tab tray tweaks

We are *almost* there with our new tabs tray, there are just a few remaining bits of polish and interaction refinements we need to address:

1. Keep the tab counter in the top bar when we open the tray. This way, users don't have to reach down to close the tray and can just tap the same spot twice. As a result, we'll want to move the + and Remote Tab icons to the left.

2. Put a divider line between the tab counter and the other icons in the header

3. Add a subtle shadow under the top bar, and above the Title Bar, so the tabs tray actually looks like a physical tray that slides underneath.

4. Keep the tab shape in the top right corner of the screen, so the transition from closed tabs to open tabs feels more natural

5. Move header and content down further when the tabs tray is open, to allow more tabs area to be shown. The header and content should occupy only about 20% of the screen area.

A mockup of all these notes is attached here.
Comment 1 User image Ian Barlow (:ibarlow) 2012-06-26 12:41:19 PDT
Created attachment 636836 [details]
Mockup of tablet tweaks

As per Sriram's request, here is an equivalent mockup for the tabs menu on tablets.
Comment 2 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-07-20 08:34:19 PDT
Ian - are these tweaks still the "current design"? The phone mockup for example does not show the menu button in the rightmost position when the tray is open.
Comment 3 User image Ian Barlow (:ibarlow) 2012-07-20 08:39:38 PDT
No, these mockups are out of date -- the tray has been updated in other bugs. The only outstanding issue here is: 

5. Move header and content down further when the tabs tray is open, to allow more tabs area to be shown. The header and content should occupy only about 20% of the screen area.

Note You need to log in before you can comment on or make changes to this bug.