Last Comment Bug 808598 - [contacts] do not show the no-contacts page as background when the app starts
: [contacts] do not show the no-contacts page as background when the app starts
Status: RESOLVED INVALID
:
Product: Firefox OS
Classification: Client Software
Component: Gaia::Contacts (show other bugs)
: unspecified
: Other Gonk (Firefox OS)
-- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
: 814772 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 08:56 PST by Maria Angeles Oteo (:oteo)
Modified: 2013-05-20 09:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Loading_Contacts_image_with_Background (13.81 KB, image/png)
2012-11-05 08:56 PST, Maria Angeles Oteo (:oteo)
no flags Details

Description User image Maria Angeles Oteo (:oteo) 2012-11-05 08:56:28 PST
Created attachment 678340 [details]
Loading_Contacts_image_with_Background

When the app starts and contacts are loading, is easy to see the first time page with create contact and import info as background (even when there are contacts already created). This is little confuse for the user. See image attached
Comment 1 User image alberto.pastor 2012-11-21 22:52:44 PST
What should we see instead? May be we need UX help here.
Note: we cannot put the contacts list. If we already had the list we wouldn't need the Loading overlay :)
Comment 2 User image alberto.pastor 2012-11-26 12:54:18 PST
*** Bug 814772 has been marked as a duplicate of this bug. ***
Comment 3 User image alberto.pastor 2012-11-26 12:56:29 PST
I like the "opaque overlay" solution that Cassey proposed on https://bugzilla.mozilla.org/show_bug.cgi?id=814772#c1 

Victoria?
Comment 4 User image Victoria Gerchinhoren [:vicky] 2012-11-27 01:26:30 PST
You need to show a loading message in the white canvas. It should have the loading spinnner on the left, like it is here (it is a BB):
http://mozilla-b2g.github.com/Gaia-UI-Building-Blocks/#widgets/progress_activity/

The one that says "Loading messages from server".
Comment 5 User image alberto.pastor 2012-11-27 08:52:38 PST
Thanks Victoria, I will apply that BB, but appart from that, the question of this bug is if we can make it opaque instead of semitransparent. The main problem is that we don't have any contact until the overlay is hidden, and showing "No Contacts" through the semitransparent overlay seems to be a little bit confusing. What do you think?
Comment 6 User image Victoria Gerchinhoren [:vicky] 2012-11-27 08:56:30 PST
I was reffering to not having an overlay, since there's no need, they are used in different scenarios. I think in this case needs to be the loading message and spinner in the "white canvas" as I said. This means the screen white background instead of the overlay. Does that make sense to you?
Comment 7 User image alberto.pastor 2013-05-20 09:21:24 PDT
I think this bug is not valid anymore. Reopen if needed

Note You need to log in before you can comment on or make changes to this bug.