Last Comment Bug 917397 - WARNING: nsWindow::GetNativeData not implemented for this type: PuppetWidget.cpp, line 633
: WARNING: nsWindow::GetNativeData not implemented for this type: PuppetWidget....
Status: RESOLVED DUPLICATE of bug 706765
:
Product: Core
Classification: Components
Component: Widget (show other bugs)
: Trunk
: x86 Linux
P4 normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jim Mathies [:jimm]
Mentors:
Depends on: 706765
Blocks: font-inflation core-e10s
  Show dependency treegraph
 
Reported: 2013-09-17 10:18 PDT by Scott Johnson (:jwir3)
Modified: 2014-04-17 14:35 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
-


Attachments

Description User image Scott Johnson (:jwir3) 2013-09-17 10:18:31 PDT
+++ This bug was initially created as a clone of Bug #706765 +++

STR:

1) Enable e10s by going to about:config and setting browser.tabs.remote to true.
2) Restart firefox.
3) Navigate to jsconsole.com
4) Input: "window.screen.width", and notice the warning about PuppetWidget not implementing GetNativeData.

Backtrace (NOTE: I changed it to an assertion to more easily debug. Please disregard this):

#0  mozilla::widget::PuppetWidget::GetNativeData (this=0x891ac0, aDataType=0)
    at /home/sjohnson/Source/mozilla-central/mozilla/widget/xpwidgets/PuppetWidget.cpp:672
#1  0x00007ffff3dfe82a in nsDeviceContext::FindScreen (this=0xd5bd90, outScreen=0x7fffffff7230)
    at /home/sjohnson/Source/mozilla-central/mozilla/gfx/src/nsDeviceContext.cpp:635
#2  0x00007ffff3dfef2c in nsDeviceContext::ComputeFullAreaUsingScreen (this=0xd5bd90, outRect=0x7fffffff72b8)
    at /home/sjohnson/Source/mozilla-central/mozilla/gfx/src/nsDeviceContext.cpp:611
#3  0x00007ffff3dfefd8 in nsDeviceContext::GetRect (this=<optimized out>, aRect=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/gfx/src/nsDeviceContext.cpp:450
#4  0x00007ffff4440f99 in nsScreen::GetRect (this=<optimized out>, aRect=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/dom/base/nsScreen.cpp:135
#5  0x00007ffff4fa8e94 in GetWidth (aRv=..., this=0xaf96a0)
    at /home/sjohnson/Source/mozilla-central/mozilla/dom/base/nsScreen.h:54
#6  mozilla::dom::ScreenBinding::get_width (cx=0xa21940, obj=..., self=0xaf96a0, args=...)
    at /home/sjohnson/Source/mozilla-central/obj-debug/dom/bindings/ScreenBinding.cpp:76
#7  0x00007ffff4fa9394 in mozilla::dom::ScreenBinding::genericGetter (cx=0xa21940, argc=<optimized out>, vp=0x7fffffff79c8)
    at /home/sjohnson/Source/mozilla-central/obj-debug/dom/bindings/ScreenBinding.cpp:510
#8  0x00007ffff57d30c9 in js::CallJSNative (cx=0xa21940, 
    native=0x7ffff4fa92ac <mozilla::dom::ScreenBinding::genericGetter(JSContext*, unsigned int, JS::Value*)>, args=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/jscntxtinlines.h:218
#9  0x00007ffff57c8060 in js::Invoke (cx=cx@entry=0xa21940, args=..., construct=construct@entry=js::NO_CONSTRUCT)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:478
#10 0x00007ffff57c8bf3 in js::Invoke (cx=cx@entry=0xa21940, thisv=..., fval=..., argc=argc@entry=0, argv=argv@entry=0x0, 
    rval=...) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:528
#11 0x00007ffff57c8d3c in js::InvokeGetterOrSetter (cx=0xa21940, obj=0x7fffe824f840, fval=..., argc=0, argv=0x0, rval=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:599
#12 0x00007ffff59f297c in js::Shape::get (this=<optimized out>, cx=cx@entry=0xa21940, receiver=receiver@entry=..., 
    obj=<optimized out>, pobj=<optimized out>, vp=...) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Shape-inl.h:69
#13 0x00007ffff59dfb0f in NativeGetInline<(js::AllowGC)1> (cx=cx@entry=0xa21940, obj=obj@entry=..., receiver=receiver@entry=..., 
    pobj=pobj@entry=..., shape=..., shape@entry=..., vp=..., getHow=<optimized out>)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/jsobj.cpp:4067
#14 0x00007ffff59dfe46 in GetPropertyHelperInline<(js::AllowGC)1> (cx=0xa21940, obj=..., receiver=..., id=..., vp=..., 
    getHow=<optimized out>) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/jsobj.cpp:4242
#15 0x00007ffff57d47c9 in GetPropertyOperation (cx=cx@entry=0xa21940, fp=<optimized out>, script=..., script@entry=..., 
    pc=<optimized out>, lval=..., vp=...) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:281
#16 0x00007ffff57c26aa in Interpret (cx=cx@entry=0xa21940, state=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:2293
#17 0x00007ffff57c74cd in js::RunScript (cx=cx@entry=0xa21940, state=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:435
#18 0x00007ffff57c774a in RunScript (state=..., cx=0xa21940)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:404
#19 js::ExecuteKernel (cx=0xa21940, script=..., scopeChainArg=..., thisv=..., type=<optimized out>, evalInFrame=..., 
    result=0x7fffffff9038) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/vm/Interpreter.cpp:619
#20 0x00007ffff5cae90b in EvalKernel (cx=cx@entry=0xa21940, args=..., evalType=evalType@entry=INDIRECT_EVAL, caller=..., 
    scopeobj=..., pc=pc@entry=0x0) at /home/sjohnson/Source/mozilla-central/mozilla/js/src/builtin/Eval.cpp:331
#21 0x00007ffff5caff67 in js::IndirectEval (cx=0xa21940, argc=<optimized out>, vp=<optimized out>)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/builtin/Eval.cpp:408
#22 0x00007ffff57d30c9 in js::CallJSNative (cx=0xa21940, 
    native=0x7ffff5cafcb0 <js::IndirectEval(JSContext*, unsigned int, JS::Value*)>, args=...)
    at /home/sjohnson/Source/mozilla-central/mozilla/js/src/jscntxtinlines.h:218
Comment 1 User image Chris Peterson [:cpeterson] 2013-12-04 14:19:43 PST
I also see these warnings on http://www.thinkbroadband.com/
Comment 2 User image Chris Peterson [:cpeterson] 2013-12-18 12:16:17 PST
and http://nytimes.com
Comment 3 User image Chris Peterson [:cpeterson] 2014-04-11 15:54:20 PDT
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
Comment 4 User image Brad Lassey [:blassey] (use needinfo?) 2014-04-17 14:35:03 PDT
not sure why this was cloned

*** This bug has been marked as a duplicate of bug 706765 ***

Note You need to log in before you can comment on or make changes to this bug.