The default bug view has changed. See this FAQ.
Last Comment Bug 917559 - Old hardware/ril preventing hamachi devices from making calls.
: Old hardware/ril preventing hamachi devices from making calls.
Status: RESOLVED FIXED
:
Product: Firefox OS
Classification: Client Software
Component: GonkIntegration (show other bugs)
: unspecified
: ARM Gonk (Firefox OS)
-- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-17 15:15 PDT by k
Modified: 2014-03-10 13:47 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image k 2013-09-17 15:15:05 PDT
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130903162616

Steps to reproduce:

After flashing hamachi build to Alcatel One Touch Fire, commercial version with stock 1.0.1 firmware, it's impossible to make calls.

It's the same problem as described here:
https://bugzilla.mozilla.org/show_bug.cgi?id=877757
which in turn was because of:
https://bugzilla.mozilla.org/show_bug.cgi?id=872992

Both bugs were fixed for leo but they are not fully working for hamachi. This is because after applying https://github.com/mozilla-b2g/b2g-manifest/pull/83, "hardware/ril" is still hardcoded to old revision "86ddf397767be35acc8d625ade69767189a17d61".

Using "hardware/ril" from b2g/ics_strawberry_v1 fixes the problem.
Comment 2 User image Jarek 2013-09-17 15:26:25 PDT
I confirm both the fact that the bug exists in the current v1-train and that the fix proposed in Comment #1 solves it. Verified with the actual Alcatel One Touch Fire device.
Comment 3 User image Michael Wu [:mwu] 2013-09-18 07:19:24 PDT
Huh, that's really not suppose to be hardcoded. I think git did some magic here and failed - all hardcodes except for gtest were suppose to be removed in bug 872992, and the commit itself did remove it. Thanks for catching this.
Comment 4 User image Michael Wu [:mwu] 2013-09-18 07:21:31 PDT
https://github.com/mozilla-b2g/b2g-manifest/pull/102 merged.
Comment 5 User image Johannes W 2014-03-10 13:47:12 PDT
There seems to be a very similar issue with hamachi.xml in https://bugzilla.mozilla.org/show_bug.cgi?id=971353.

Note You need to log in before you can comment on or make changes to this bug.