Last Comment Bug 92466 - can select options within the OPTGROUP (the disabled attribute has ben set)
: can select options within the OPTGROUP (the disabled attribute has ben set)
Status: VERIFIED FIXED
:
Product: Core
Classification: Components
Component: Layout: Form Controls (show other bugs)
: Trunk
: x86 Windows 2000
defect
-- normal (vote)
: Future
Assigned To: rods (gone)
: Madhur Bhatia
: Sean Voisen (:svoisen) [On PTO until May 6]
Mentors:
Depends on: 34297
Blocks:
  Show dependency treegraph
Regressions:
Regressed by:
 
Reported: 2001-07-26 13:02 PDT by Madhur Bhatia
Modified: 2001-11-28 15:45 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test case (873 bytes, text/html)
2001-07-26 13:03 PDT, Madhur Bhatia
no flags Details

Description User image Madhur Bhatia 2001-07-26 13:02:45 PDT
1. open the testcase provided below
2. tab to the control
3. use the keyboard up-down arrow keys to navigate within the control and make 
selection.

actual:
you will notice that if you use the up-down arrows, u are able to select the 
options that are enclosed within the OPTGROUP - "ground" (which has the disabled 
property set)

whereas, if you mouse-click on these options ("bus", "car") under disabled 
Optgroup ("ground") you are not able to make the selection

expected:
since the optgroup as whole has been set to 'disabled', the user should not be 
able to make a selection of the options within this control - neither by 
mouse-click(which behaves correctly) nor by keyboard selection (this is not 
working as desired).
Comment 1 User image Madhur Bhatia 2001-07-26 13:03:40 PDT
Created attachment 43703 [details]
test case
Comment 2 User image Madhur Bhatia 2001-07-26 13:05:01 PDT
Note: even the disabled OPTGROUP is not greyed out - as any other disabled 
form-control is supposed to be.
Comment 3 User image John Keiser (jkeiser) 2001-10-07 10:46:51 PDT
This is fixed in the patch for bug 34297.  Setting dependent.
Comment 4 User image John Keiser (jkeiser) 2001-11-02 22:14:38 PST
Fixed with bug 34297 landing.
Comment 5 User image Madhur Bhatia 2001-11-08 15:38:18 PST
verified fixed on 
win2000 build ID: 2001-11-08-06trunk
macOS 9.1 buildID : 2001-11-08-08trunk
Comment 6 User image Madhur Bhatia 2001-11-28 11:50:54 PST
The fix for this bug only shows in the trunk builds.

I can still reproduce the bug in 0.9.4 branch build + the 6.2.1 rtm builds --- 
on all platforms.

Please move the patch to the 6.2.1 rtm builds, as well. Reopening bug as a 
reminder to check in the patch in the next release. Thanks!
Comment 7 User image John Keiser (jkeiser) 2001-11-28 15:42:33 PST
This was a part of the massive bug 34297 patch.  If you want to check *that* in
to NS6.2, you're a brave man :)  Please reassess this reopening--if this is
critical to that release, an entirely new patch will have to be spun.
Comment 8 User image lchiang 2001-11-28 15:45:16 PST
Madhur, the fix for this bug (plus 34297) wasn't made until after the 094 branch
was cut and the fix was only applied to the trunk.  

There was not any intention or nomination of this bug to be applied back to the
094 branch.

I'll cc: marek to see if he needs this for our embedding customer.  If so, we
should just open a new bug to apply this fix.

I'm going to mark this bug fixed and verified again.
Comment 9 User image lchiang 2001-11-28 15:45:48 PST
mark verified.

Note You need to log in before you can comment on or make changes to this bug.