Last Comment Bug 954411 - Unread count hard to read on Dock icon
: Unread count hard to read on Dock icon
Status: RESOLVED FIXED
:
Product: Instantbird
Classification: Client Software
Component: Other (show other bugs)
: 1.0
: x86 macOS
defect
-- normal
: 1.1
Assigned To: Florian Quèze [:florian]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
Regressions:
Regressed by:
 
Reported: 2013-12-29 23:42 PST by Patrick Cloke [:clokep]
Modified: 2013-12-30 00:10 PST (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Dock icon screenshot (15.62 KB, image/png)
2013-12-29 23:42 PST, Patrick Cloke [:clokep]
no flags Details
Mail.app dock badge (11.90 KB, image/png)
2013-12-30 00:10 PST, Florian Quèze [:florian]
no flags Details

Description User image Patrick Cloke [:clokep] 2013-12-29 23:42:50 PST
*** Original post on bio 977 at 2011-08-24 01:17:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
Comment 1 User image Patrick Cloke [:clokep] 2013-12-29 23:42:51 PST
Created attachment 8352526 [details]
Dock icon screenshot

*** Original post on bio 977 as attmnt 784 at 2011-08-24 01:17:00 UTC ***

The unread count on the Dock icon can be hard to read over the release icon.

The color is defined at http://lxr.instantbird.org/instantbird/source/purple/purplexpcom/src/nsDockTile.cpp#89

I'm not sure of what a better color is (begin the bikeshedding...)

If we can come up w/ a better color I'm willing to do the patch for it. (I'm not sure if we could make it configurable / whether it'd be worth it, but it's something to consider.)
Comment 2 User image Florian Quèze [:florian] 2013-12-30 00:10:19 PST
Created attachment 8352610 [details]
Mail.app dock badge

*** Original post on bio 977 as attmnt 867 at 2011-10-06 19:52:00 UTC was without comment, so any subsequent comment numbers will be shifted ***
Comment 3 User image Florian Quèze [:florian] 2013-12-30 00:10:23 PST
*** Original post on bio 977 at 2011-10-06 22:59:19 UTC ***

As we no longer support Mac OS X 10.4, we can just use the Cocoa API -> nice code reduction: https://hg.instantbird.org/instantbird/rev/f7a0a00d2a7f :-)

Note You need to log in before you can comment on or make changes to this bug.