Last Comment Bug 100000 - 100 000! Celebrate!
: 100 000! Celebrate!
Status: VERIFIED WONTFIX
:
Product: Bugzilla
Classification: Server Software
Component: Bugzilla-General (show other bugs)
: unspecified
: All All
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-16 23:24 PDT by Henrik Gemal
Modified: 2014-07-17 09:36 PDT (History)
19 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Henrik Gemal 2001-09-16 23:24:31 PDT
Error: [Exception... "Component returned failure code: 0x80004005
(NS_ERROR_FAILURE) [nsIRDFContainer.Init]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://communicator/content/bookmarks/bookmarksOverlay.js :: anonymous :: line
594"  data: no]
Source File: chrome://communicator/content/bookmarks/bookmarksOverlay.js
Line: 594

build 20010914
Comment 1 Matthew Paul Thomas 2001-09-16 23:30:36 PDT
You're no fun.
Comment 2 Ben Bucksch (:BenB) 2001-09-16 23:37:27 PDT
Turing this into a celebration bug...

I filed bug 100006 for th actual bug instead.
Comment 3 Ben Bucksch (:BenB) 2001-09-16 23:40:01 PDT
bugzilla.mozilla.org reached bug number 100 000!

Congratulation to the BugZilla development team and those who administer
bugzilla.mozilla.org.

This bug (and the installation behind it) is proof that BugZilla scales very
well to huge projects. From my own experience, the speed is still good.

During usage, BugZilla evolved to a very comfortable web platform for
filing/tracking bugs, one that has only very few competition (of which I know).
Examples are the emailing and dependency systems. In fact, BugZilla is probably
the most important communication medium used in the Mozilla project (apart from
the source code itself :-) ).

All the people making it work deserve a big "Thanks".

Maybe you want to attach / refer to some anecdotes around BugZilla or the "life"
in bugzilla.mozilla.org.
Comment 4 Ben Bucksch (:BenB) 2001-09-16 23:40:23 PDT
Lurkers:
Just for those lurkers of you who might think "Oh, Mozilla had so many bugs":
BugZilla is used to track work on Mozilla. Every bit of work has to have a bug
here. This includes new features and bugs found by developers/testers during
development (bugs that never reached users). So, the number of filed closed bugs
cannot be used as criteria of the quality of Mozilla.
Comment 5 Matthew Paul Thomas 2001-09-16 23:52:02 PDT
In addition to those feature bugs, and invalid bugs, and bugs used for tracking 
purposes, we get a *lot* of duplicate bug reports.

Such as this one, for example.

*** This bug has been marked as a duplicate of 9940 ***
Comment 6 Alex Vincent [:WeirdAl] 2001-09-17 00:02:03 PDT
That didn't take very long from my comment earlier today...

You also gotta remember dupes, invalids, worksforme... all of which never get 
dropped from the actual Bugzilla database.  So, no celebrations at 
MozillaQuest, please!

all your bugs are belong to us.  Move Zilla, for great browser.
Comment 7 Alex Vincent [:WeirdAl] 2001-09-17 00:09:20 PDT
For the record, the earliest bug number in the database is bug # 35.  At this 
time, bug #100035 does not exist.

Not that it matters...
Comment 8 Ben Bucksch (:BenB) 2001-09-17 00:10:01 PDT
> *** This bug has been marked as a duplicate of 9940 ***

This *is* the celebration.

> we get a *lot* of duplicate bug reports.

And a lot of discussion. Reopening ;-P.
Comment 9 Alex Vincent [:WeirdAl] 2001-09-17 00:28:24 PDT
YOU GOTTA FIGHT

FOR YOUR RIGHT

TO DEEEEEEEEEEBUG
Comment 10 Doron Rosenberg (IBM) 2001-09-17 01:18:14 PDT
for he's a jolly good fellow, for he's a ...well, might be a female. Asa can
probably go check!
Comment 11 basic 2001-09-17 04:22:28 PDT
so anybody want to take this? ;-p
Comment 12 Matthew Tuck [:CodeMachine] 2001-09-17 04:53:55 PDT
If it wasn't for Bugzilla, I'd still be a socially inept geeky programmer with
no hope of ever getting laid.  But now, I'm the coolest of the cool and have
woman throwing themselves all over me.
Comment 13 gabriel 2001-09-17 06:14:36 PDT
Even Slashdot has a story on it !

http://slashdot.org/article.pl?sid=01/09/17/1231204&mode=thread

Congratulations everybody :-)

Comment 14 Håkan Waara 2001-09-17 06:29:24 PDT
Let's party like it's bug 100,000!!!!!!
Comment 15 Emlyn Shannon 2001-09-17 06:35:05 PDT
And a few of the slashdot posters are being almost reasonable, too. Truely, the
100,000th bug marks an entirely new age of mankind.
Comment 16 Jerome Lacoste 2001-09-17 06:36:35 PDT
Actually looking at the comments in Bug 9940, Bugzilla has a bug it doesn't
handle well numbers with space (e.g. 100 000, instead of 100000)

:)
Comment 17 Jacob Steenhagen 2001-09-17 06:50:18 PDT
That's a bug in the way the number's typed, not in the way bugzilla links it ;)
Comment 18 Alex Bishop 2001-09-17 07:52:40 PDT
So who won the 100,000 bug sweepstakes? I know it wasn't me because I predicted
the 100,000th bug would be filed about a week ago.
Comment 19 Henrik Gemal 2001-09-17 08:31:53 PDT
Please define "100,000 bug sweepstakes"?
If you mean who filed it, it's me...:)
Comment 20 Alex Vincent [:WeirdAl] 2001-09-17 08:32:45 PDT
There was a sweepstakes?  They didn't mention that at mozilla.party this 
year... ;)
Comment 21 John "AntiTuX" Dee 2001-09-17 08:54:33 PDT
so does this mean more doughnuts and really cheap champagne?
Comment 22 Gervase Markham [:gerv] 2001-09-17 10:31:28 PDT
The date of filing of Bug 100000 was: 2001-09-16 23:24

And the winner is...      Niko Pavlicek!


2001-09-20 11:11:11 <niko_pavlicek@web.de> Niko Pavlicek
Error: 3 days, 11 hours and 47 mins

Runners up:

2001-09-20 13:15:37 <andersma@luther.edu>  Mark Anderson
Error: 3 days, 13 hours and 51 mins

2001-09-21 10:10:10 <jonasj@jonasj.dk>     Jonas Jorgensen     
Error: 4 days, 10 hours and 46 mins

Honourable mentions:
2001-09-10 13:37:42 <alexbishopuk@yahoo.com>
2001-09-23 13:07:20 <jesusx@who.net>
2001-09-23 17:08:31 <pgp1@cornell.edu>
2001-09-24 10:10:10 <psolanki@netscape.net>
2001-09-24 20:15:30 <greg@tcp.com>

Gerv
Comment 23 Jonas Jørgensen 2001-09-17 11:13:16 PDT
My name is Jonas Jørgensen with the danish letter ø (&oslash;), not Jonas 
Jorgensen. Not that I expect anyone to care...
Comment 24 Alex Bishop 2001-09-17 11:33:02 PDT
Woohoo! I came fourth!

For anyone who doesn't know, the 100,000 bug sweepstake was a fun little contest
organised by Gerv in netscape.public.mozilla.general to guess the exact date and
time that the 100,000th bug would be filed in Mozilla.

You can read the original newsgroup posting announcing the contest here:
http://groups.google.com/groups?hl=en&selm=3B79E8B7.ECBA88DD%40mozilla.org
Comment 25 Brian 'netdragon' Bober 2001-09-20 20:03:03 PDT
We gonna party all night long!

Well my friends the time has come
To raise the roof and have some fun
Throw away the work to be done
Let the music play on ...
Everybody sing, everybody dance
Lose yourself in wild romance
We're going to parti', karamu', fiesta, forever
Come on and sing along
We're going to parti', karamu', fiesta, forever
Come on and sing along

All night long (all night), All night (all night)
All night long (all night), All night (all night)
All night long (all night), All night (all night)
All night long (all night), Ooh yeah (all night)

People dancing all in the street
See the rhythm all in their feet
Life is good, wild and sweet
Let the music play on ...
Feel it in your heart and feel it in your soul
Let the music take control
We're going to parti', liming, fiesta, forever
Come on and sing along
We're going to parti', liming, fiesta, forever
Come on and sing my song

All night long (all night), Ooh (all night)
All night long (all night), Yeah (all night)
All night long (all night), Yeah (all night)
All night long (all night), ... (all night)

Yeah, once you get started you can't sit down
Come join the fun, it's a merry-go-round
Everyone's dancing their troubles away
Come join our party, see how we play!

Tom bo li de say de moi ya
Yeah, jambo jumbo
Way to parti' o we goin'
Oh, jambali
Tom bo li de say de moi ya
Yeah, jumbo jumbo!

Oh, O, O, O, Yes
We're gonna have a party, Yeah, ugh
All night long (all night), All night (all night)
All night long (all night), Yeah (all night)
All night long (all night), All night (all night)
All night long (all night), Whoa...

We're going to (parti'), Oh (karamu'), Yeah (fiesta) forever
Come on and sing along
We're going to (parti'), OOH (karamu'), Yeah (fiesta) forever
Come on and sing my song

All night long (all night), All night (all night)
All night long (all night), All night (all night)
All night long (all night), All night (all night)
All night long (all night), Ugh (all night)
All night (all night)
All night (all night)
All night (all night)
All night (all night)
All night (all night)
All night (all night)
All night (all night)
All night (all night), Ugh

Everyone you meet (all night)
They're jamming in the street (all night)
All night long (all night)
Yeah, I said (all night)
Everyone you meet (all night)
They're jamming in the street (all night)
All night long (all night)
Feel good, feel good (all night)
Feel good (all night)
All night long (all night)
Yeah (all night)
What more can I say (all night)
Let the music play (all night)
All night long (all night)
(Adlib to Fade)
Comment 26 John "AntiTuX" Dee 2001-09-21 00:12:11 PDT
Dude, you *REALLY* need to lay off whatever you've been smoking.. or pass it my
way.. :)
Comment 27 Alex Vincent [:WeirdAl] 2001-09-21 06:33:54 PDT
What music is that set to?  Or is that just a freelance rap?
Comment 28 John "AntiTuX" Dee 2001-09-21 08:57:44 PDT
I remember that song. it came out in the 80's. hrm. can't remember the name of
it though. oh well, who cares? he's still smoking too much crack :P
Comment 29 Dwayne 2001-09-22 17:29:59 PDT
Guys, it's Lionel Ritchie, and I believe it came out in the early '80s like 83-84.
Comment 30 John "AntiTuX" Dee 2001-09-23 02:03:02 PDT
that'd explain why I don't recognize it. I was born in '81 :P
Comment 31 Brian 'netdragon' Bober 2001-09-23 14:18:17 PDT
Heh, I was born in '80 :-)
Comment 32 Matthew Tuck [:CodeMachine] 2001-11-15 19:08:11 PST
WONTFIX.  The Bugzilla team is too busy working on quality software that we have
no time for celebration.
Comment 33 Alex Vincent [:WeirdAl] 2001-11-15 20:40:33 PST
That is a most illogical comment.  Once we reach 1.0 we will have quality
software and the Bugzilla team will not need to work so hard.  We most certainly
can have a most righteous bash.

REOPENING because the resolution wontfix is incorrect in the extreme.  I'll have
to work on a JS-based patch which includes strobe lights and some heavy bass.
Comment 34 Matthew Tuck [:CodeMachine] 2001-11-16 00:54:22 PST
Bugzilla progress has nothing to do with Mozilla progress, nor any "1.0"
milestone.
Comment 35 Alex Vincent [:WeirdAl] 2001-11-16 06:19:01 PST
Oh, sorry.  Wrong bug entirely.  Apologies for the spam, and resetting WONTFIX.
Comment 36 Brian 'netdragon' Bober 2001-11-16 20:58:23 PST
In all fairness, I think this should be marked Fixed as not to hurt Henrik's
Fixed/Notfixed ratio. :-)
Comment 37 Dave Miller [:justdave] (justdave@bugzilla.org) 2002-02-03 22:59:08 PST
clearing target milestone on resolved non-FIXED bugs so they'll get re-triaged
if they get reopened.
Comment 38 Henrik Gemal 2002-02-22 13:31:57 PST
v
Comment 39 Michael 2004-05-28 11:07:07 PDT
*** Bug 244990 has been marked as a duplicate of this bug. ***
Comment 40 Maximilian Capraro 2013-05-01 13:33:42 PDT
Late Congratulations from my side. It was a very funny adventure to browse through the old issue tracker entries and find this one :-)
Comment 41 juan becerra [:juanb] 2013-05-28 11:56:38 PDT
Created attachment 754933 [details]
this is a test

Note You need to log in before you can comment on or make changes to this bug.