after selecting partial URI, entire URI is selected on right click

VERIFIED DUPLICATE of bug 96446

Status

SeaMonkey
Location Bar
--
minor
VERIFIED DUPLICATE of bug 96446
17 years ago
10 years ago

People

(Reporter: Brian Z Jones, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
BuildID: 2001091303

When selecting part of a URI in the address bar, then right-clicking, the entire
URI is selected.

Reproducible: Always

Steps to Reproduce:
1. Highlight part of a current URI in the address bar.
2. Right click to get the Copy/Paste/Delete dialog.
3. Entire URI is then selected.

Expected Results:  The same part that was highlighted should have stayed
selected, to allow for Copying/Pasting/Deletion.

This is easily worked around via keyboard commands, but sometimes when viewing
an article form a new site, I like to then go to the top-level of the site and
see what the site is all about. I usually just hightlight everyting after
"http://foo.tld", right-click and delete, then hit "Go" - more convenient than
reaching for the keyboard at times.

Comment 1

17 years ago
I don't know if this is by design or a bug, but confirming that it happens. 
Builg 2001091508, Win98.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

17 years ago
Annoying as hell when you want to use the context menu to delete part of the URL.

Comment 3

17 years ago
I think this is related, and gets to the heart of the matter. It is really hard
to edit a URL in the URL bar. Almost always, you want ot change the end of a
URL. But clicking in the middle of a URL highlights it to the start instead of
to the end! There seems to be no easy way to highlight to the end. Dragging it
from the clicl location leaves the start selected.

Comment 4

17 years ago
I saw this in 0.9.5 until I added the line

user_pref("browser.urlbar.clickSelectsAll", false)

to my prefs.js. Now when I right click the URL bar, it doesnt 
select everything anymore. 

Comment 5

17 years ago
Joe was dying to have these bugs. Who am I to say no?
Assignee: blakeross → hewitt

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 96446 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.